Bug 1779546 - MCO fails to apply rendered configuration to infra nodes
Summary: MCO fails to apply rendered configuration to infra nodes
Keywords:
Status: CLOSED DUPLICATE of bug 1772680
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Antonio Murdaca
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-04 08:16 UTC by Jaspreet Kaur
Modified: 2019-12-04 11:34 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-04 11:34:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jaspreet Kaur 2019-12-04 08:16:33 UTC
Description of problem: When using a custom machine config pool for infra nodes, the MCO fails to manage the rolling update when a new worker node is labeled to infra.

Followed this article to create Infra node in OCP 4.2.2: https://access.redhat.com/solutions/4287111

 Re-labelled Infra node with Worker role
- Able to successfully complete upgrade to 4.2.4

Attached logs and extract:

E1204 03:01:08.512339       1 event.go:247] Could not construct reference to: '&v1.ConfigMap{TypeMeta:v1.TypeMeta{Kind:"", APIVersion:""}, ObjectMeta:v1.ObjectMeta{Name:"machine-config-controller", GenerateName:"", Namespace:"openshift-machine-config-operator", SelfLink:"/api/v1/namespaces/openshift-machine-config-operator/configmaps/machine-config-controller", UID:"a4286c05-1576-11ea-932f-0050568d1112", ResourceVersion:"519540", Generation:0, CreationTimestamp:v1.Time{Time:time.Time{wall:0x0, ext:63710937789, loc:(*time.Location)(0x28f62e0)}}, DeletionTimestamp:(*v1.Time)(nil), DeletionGracePeriodSeconds:(*int64)(nil), Labels:map[string]string(nil), Annotations:map[string]string{"control-plane.alpha.kubernetes.io/leader":"{\"holderIdentity\":\"machine-config-controller-79fb44cf59-4rvjg_0ceb829f-1642-11ea-8244-0a580af71a72\",\"leaseDurationSeconds\":90,\"acquireTime\":\"2019-12-04T03:01:08Z\",\"renewTime\":\"2019-12-04T03:01:08Z\",\"leaderTransitions\":18}"}, OwnerReferences:[]v1.OwnerReference(nil), Initializers:(*v1.Initializers)(nil), Finalizers:[]string(nil), ClusterName:"", ManagedFields:[]v1.ManagedFieldsEntry(nil)}, Data:map[string]string(nil), BinaryData:map[string][]uint8(nil)}' due to: 'no kind is registered for the type v1.ConfigMap in scheme "github.com/openshift/machine-config-operator/cmd/common/helpers.go:30"'. Will not report event: 'Normal' 'LeaderElection' 'machine-config-controller-79fb44cf59-4rvjg_0ceb829f-1642-11ea-8244-0a580af71a72 became leader'
E1204 03:01:08.547355       1 runtime.go:69] Observed a panic: "invalid memory address or nil pointer dereference" (runtime error: invalid memory address or nil pointer dereference)

Version-Release number of selected component (if applicable):


How reproducible:
https://github.com/openshift/machine-config-operator/blob/master/docs/custom-pools.md
Followed : https://access.redhat.com/solutions/4287111



Actual results: Fails to upgrade when custom infra pool is created


Expected results: Should upgrade without issues.


Additional info:

Comment 1 Antonio Murdaca 2019-12-04 11:34:48 UTC

*** This bug has been marked as a duplicate of bug 1772680 ***


Note You need to log in before you can comment on or make changes to this bug.