Bug 1779642 - Organization and Location fields are missing from output of 'hammer http-proxy info' command.
Summary: Organization and Location fields are missing from output of 'hammer http-prox...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: 6.7.0
Assignee: Chris Roberts
QA Contact: Jameer Pathan
URL:
Whiteboard:
Depends On:
Blocks: 1774324 1774325
TreeView+ depends on / blocked
 
Reported: 2019-12-04 12:30 UTC by Jameer Pathan
Modified: 2020-04-14 15:54 UTC (History)
7 users (show)

Fixed In Version: tfm-rubygem-hammer_cli_foreman-0.19.6.2-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-14 15:54:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 28472 Normal Closed Organization and Location fields are missing from output of 'hammer http-proxy info' command. 2020-10-19 13:17:43 UTC
Red Hat Product Errata RHBA-2020:1455 None None None 2020-04-14 15:54:21 UTC

Description Jameer Pathan 2019-12-04 12:30:51 UTC
Description of problem:
Organization and Location fields are missing from output of 'hammer http-proxy info' command.

Version-Release number of selected component (if applicable):
- Satellite 6.7.0 snap 4
- tfm-rubygem-hammer_cli-0.19.0-2.el7sat.noarch

How reproducible:
- Always

Steps to Reproduce:
1. Create HTTP Proxy with organization and Location assigned to them.
# hammer http-proxy create --name proxy4 --url https://proxy4 --organization-id 1 --location-id 2

2. Run 'hammer http-proxy info --id 4'

Actual results:
# hammer http-proxy info --id 4
Id:       4
Name:     proxy4
Username: 
URL:      https://proxy4

Expected results:
# hammer http-proxy info --id 4
Id:       4
Name:     proxy4
Username: 
URL:      https://proxy4
Locations:     
    Default Location
Organizations: 
    Default Organization

Additional info:

Comment 3 Shira Maximov 2019-12-10 12:48:57 UTC
Created redmine issue https://projects.theforeman.org/issues/28472 from this bug

Comment 4 Bryan Kearney 2019-12-19 23:02:11 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 5 Bryan Kearney 2019-12-19 23:02:13 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 6 Bryan Kearney 2020-01-02 11:02:20 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/28472 has been resolved.

Comment 8 Jameer Pathan 2020-01-20 14:01:40 UTC
Verified:

Verified with:
- Satellite 6.7.0 snap 9
- tfm-rubygem-hammer_cli-0.19.2-1.el7sat.noarch

Test steps:

Steps to Reproduce:
1. Create HTTP Proxy with organization and Location assigned to them.
# hammer http-proxy create --name proxy5 --url https://proxy5 --organization-ids 1,3 --location-ids 2,4

2. Run 'hammer http-proxy info --name proxy5'

Observations:
- Organization and Location fields were present in output of 'hammer http-proxy info' command.

hammer> http-proxy info --name proxy5
Id:            5
Name:          proxy5
Username:      
URL:           https://proxy5
Locations:     
    Default Location
    loc1
Organizations: 
    Default Organization
    org1

Comment 11 errata-xmlrpc 2020-04-14 15:54:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1455


Note You need to log in before you can comment on or make changes to this bug.