Bug 177981 - gnome-panel quits unexpectedly
gnome-panel quits unexpectedly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-16 18:49 EST by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-22 22:24:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Dickson 2006-01-16 18:49:38 EST
Description of problem:
gnome-panel doesn't start and loops with the message box "Application
gnome-panel has quit unexpectedly".

I'm not sure whether is is related to the gnome-volume-manager directly or just
because gnome was made more sensitive over the weekend.

Version-Release number of selected component (if applicable):
gnome-panel-2.13.4-1


How reproducible:


Steps to Reproduce:
1. Start my Gnome session via GDM
2.
3.
  
Actual results:
Looping restart of gnome-panel

Expected results:
Icons on my panels

Additional info:

Stolen from Bug-Buddy:

Backtrace was generated from '/usr/bin/gnome-panel'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1209084240 (LWP 9509)]
[New Thread -1273848928 (LWP 9512)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00dcb402 in __kernel_vsyscall ()
#0  0x00dcb402 in __kernel_vsyscall ()
#1  0x00d8780b in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x0089709d in gnome_init_with_popt_table ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x06c2d599 in g_logv () from /usr/lib/libglib-2.0.so.0
#5  0x06c2d857 in g_log () from /usr/lib/libglib-2.0.so.0
#6  0x06c2d925 in g_return_if_fail_warning () from /usr/lib/libglib-2.0.so.0
#7  0x06c12b91 in g_filename_display_basename ()
   from /usr/lib/libglib-2.0.so.0
#8  0x0808b968 in panel_menu_items_append_lock_logout ()
#9  0x0808c0bd in panel_place_menu_item_new ()
#10 0x08088004 in panel_menu_bar_load_from_gconf ()
#11 0x00328b9e in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#12 0x00310e64 in g_object_set () from /usr/lib/libgobject-2.0.so.0
#13 0x0030eb65 in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#14 0x0030f68b in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#15 0x0030f82a in g_object_new () from /usr/lib/libgobject-2.0.so.0
#16 0x08087cef in panel_menu_bar_load_from_gconf ()
#17 0x08071589 in panel_applet_load_queued_applets ()
#18 0x06c240be in g_list_remove_link () from /usr/lib/libglib-2.0.so.0
#19 0x06c257e9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0x06c2858d in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#21 0x06c288be in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#22 0x06e83fec in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x080618bb in main ()

Thread 2 (Thread -1273848928 (LWP 9512)):
#0  0x00dcb402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00cb0c10 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x06c285af in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x06c288be in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x0071ca55 in link_set_io_thread () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x06c412a4 in g_thread_create_full () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00d81262 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x00cba14e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1209084240 (LWP 9509)):
#0  0x00dcb402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00d8780b in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0089709d in gnome_init_with_popt_table ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x06c2d599 in g_logv () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#5  0x06c2d857 in g_log () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x06c2d925 in g_return_if_fail_warning () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x06c12b91 in g_filename_display_basename ()
   from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x0808b968 in panel_menu_items_append_lock_logout ()
No symbol table info available.
#9  0x0808c0bd in panel_place_menu_item_new ()
No symbol table info available.
#10 0x08088004 in panel_menu_bar_load_from_gconf ()
No symbol table info available.
#11 0x00328b9e in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#12 0x00310e64 in g_object_set () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#13 0x0030eb65 in g_object_newv () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#14 0x0030f68b in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#15 0x0030f82a in g_object_new () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#16 0x08087cef in panel_menu_bar_load_from_gconf ()
No symbol table info available.
#17 0x08071589 in panel_applet_load_queued_applets ()
No symbol table info available.
#18 0x06c240be in g_list_remove_link () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#19 0x06c257e9 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#20 0x06c2858d in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#21 0x06c288be in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#22 0x06e83fec in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#23 0x080618bb in main ()
No symbol table info available.
Comment 1 John (J5) Palmieri 2006-01-18 10:01:06 EST
Ray, I can confirm there is an issue beyond the find all critical warnings bug.
 On my machine I can get the panel to crash or freeze by adding and removing
bookmarks from File Save or File Open dialog.  Leaving bookmarks in causes the
panel to crash randomly after it has been restarted.  Removing all bookmarks
seems to make the panel stable.
Comment 2 Andy Burns 2006-01-18 14:44:37 EST
Just to add a "me too" to this, I just removed/reinstalled gnome-panel,
gnome-menu and gnome-desktop (had to do it manually due to conflicts) and I have
a broken setup in the same was as this report, at least it wasn't me wot broke
it :-)
Comment 3 Matthias Clasen 2006-02-18 00:01:25 EST
John, does this still occur on your laptop ? I haven't seen it on my machine.
Comment 4 Matthias Clasen 2006-02-21 16:42:02 EST
Andy, can you append the contents of your ~/gtk-bookmarks when the crash happens
again ?
Comment 5 Matthias Clasen 2006-02-22 22:24:42 EST
Ok, John said he does not see this any more. 
I'm going to close this. Please reopen if you can still reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.