Bug 1779858 - Create Operand: Required fields are missing "red asterisk" after specDescriptor overwrite
Summary: Create Operand: Required fields are missing "red asterisk" after specDescript...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1790612 1785102
Blocks: 1780269
TreeView+ depends on / blocked
 
Reported: 2019-12-04 21:08 UTC by Samuel Padgett
Modified: 2020-05-13 21:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, some fields that have OLM descriptors were missing the required red asterisk in the OpenShift console "Create Operand" form. The bug has been fixed, and the fields are correctly treated as a required.
Clone Of:
: 1780269 (view as bug list)
Environment:
Version: 4.4.0-0.ci-2019-12-04-051457 Cluster ID: 73e38a63-0543-4277-9bd4-018c287764e8 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0
Last Closed: 2020-05-13 21:54:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3666 'None' closed Bug 1779858: Fixed the required field display issue for create operand form 2020-05-01 12:59:13 UTC
Github openshift console pull 4272 None closed Bug 1779858: Fixed required fields display issue for create operand form 2020-05-01 12:59:13 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:54:09 UTC

Description Samuel Padgett 2019-12-04 21:08:38 UTC
https://jira.coreos.com/browse/CONSOLE-1927

All "required fields" generated based on OpenAPI Schema would show "red asterisk" for indicating as required fields.

It's noticed after those required fields got overwritten by specDescriptors, the "red asterisk" indicator for those required fields are missing.

See attached screenshots for reference.

Reproducible Steps:

    Installed Couchbase Operators to "Namespace A"
    Remove the specDescriptor for "authSecret" field from the CSV file
    Check out Creation form for CouchbaseCluster   
    --> See "authSecret" field shows "red asterisk" as required field

    Installed Couchbase Operators to "Namespace B"
    Check out Creation form for CouchbaseCluster   
    --> See "authSecret" field with specDescriptor's widget: "red asterisk" missing

Expected Behavior:

All required fields should show "red asterisk" as the indicator.

Comment 2 Yanping Zhang 2019-12-19 07:16:06 UTC
The verification is blocked, since can not create couchbase operator successfully, tracked in bug: https://bugzilla.redhat.com/show_bug.cgi?id=1785102

Comment 3 Yanping Zhang 2020-01-08 04:03:29 UTC
Checked on ocp4.3 with payload 4.3.0-0.nightly-2020-01-07-212456.
Following steps in description to test:
1.Installed Couchbase Operators to "Namespace A"
    Remove the specDescriptor for "authSecret" field from the CSV file
    Check out Creation form for CouchbaseCluster   
    --> See "authSecret" field shows "red asterisk" as required field
2.Installed Couchbase Operators to "Namespace B"
    Check out Creation form for CouchbaseCluster   
    --> See "authSecret" field with specDescriptor's widget: "red asterisk" missing
The results are the same with that in the description, seems the bug fix doesn't work.

Comment 4 Yanping Zhang 2020-01-08 04:10:47 UTC
Sorry, I should check the bug on OCP 4.4 not 4.3, ignore Comment 3.
Since the bug is still blocked by bug 1785102, will check when it can be tested.

Comment 6 Samuel Padgett 2020-02-07 22:13:52 UTC
There's a typo in the required field path in the original fix. Moving back to assigned.

Comment 8 shahan 2020-02-17 05:16:37 UTC
since couchbase operator cannot install sucessfully, here using cluster-logging instead.
1. install cluster-logging operator
2. goto ClusterLoggings creation form, noted the "Kibana Size"  has the red asterisk as required field.
3. change the displayName " Kibana Size" to "Kibana Sizetest" under specDescriptors in csv yaml.
         specDescriptors:
          - description: The desired number of Kibana Pods for the Visualization component
            displayName: Kibana Sizetest
            path: visualization.kibana.replicas
            x-descriptors:
              - 'urn:alm:descriptor:com.tectonic.ui:podCount'
4. goto ClusterLoggings creation form, noted the "Kibana Sizetest"  still has the red asterisk as required field.
verified this bug.
4.4.0-0.nightly-2020-02-16-205302

Comment 10 errata-xmlrpc 2020-05-13 21:54:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.