Bug 1779932 - Correct VM label "vm.kubevirt.io/template-namespace" to "vm.kubevirt.io/template.namespace"
Summary: Correct VM label "vm.kubevirt.io/template-namespace" to "vm.kubevirt.io/templ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Phillip Bailey
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1808300 1809577
TreeView+ depends on / blocked
 
Reported: 2019-12-05 02:57 UTC by Guohua Ouyang
Modified: 2020-07-13 17:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1808300 1809577 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:12:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4320 0 None closed Bug 1779932: Fix VM template-namespace label 2020-06-23 08:17:18 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:05 UTC

Description Guohua Ouyang 2019-12-05 02:57:27 UTC
Description of problem:
'vm.kubevirt.io/template-namespace' is the old-style for template namespace, needs update.

$ oc logs virt-template-validator-7448b5dd85-5mvhn

{"component":"kubevirt-template-validator","level":"warning","msg":"VM test1 has old-style template namespace annotation 'vm.kubevirt.io/template-namespace', should be updated to 'vm.kubevirt.io/template.namespace'","pos":"uplink.go:51","timestamp":"2019-12-04T05:28:15.758828Z"}

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-11-28-103851

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Guohua Ouyang 2020-03-31 07:11:12 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016.

Comment 5 errata-xmlrpc 2020-07-13 17:12:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.