Bug 177996 - corrupt iso images from multiple sources, SHA1 matches
corrupt iso images from multiple sources, SHA1 matches
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-16 22:51 EST by Matthew Nuzum
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 14:17:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Nuzum 2006-01-16 22:51:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

Description of problem:
I have download the CD-ROM iso images twice now, once on Thursday January 12th on my laptop via BitTorrent, a second time on Sunday Jan 15th to a desktop computer via FTP from a mirror.  The first time, the install failed so I tested the cd-roms and each of the four CD-ROMs failed the test, some as early as 12% through the process. The second time, I was more diligent and checked the SHA1 sums from the main Fedora download site... the SHA1s matched.

Because I was skeptical, I downloaded to two different computers, used two different software programs for doing the burning but arrived at the same result in both cases... coasters.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download the disk images
2. Test SHA1 - it matches
3. Burn to CD
4. Boot of disk 1
4. Peform disk test - fails
5. Try to install anway - anaconda fails with unhandled exceptions
6. Toss disk in trash.
  

Additional info:
Comment 1 David Cantrell 2006-01-17 14:14:32 EST
What anaconda failures are you seeing?  How are you burning the discs?
Comment 2 Matthew Nuzum 2006-01-17 15:19:29 EST
In the last run, the anaconda error occurred right after partitioning... at
first I tried to allow it to auto-partition the drive deleting all existing
partitions. It then gave me an error that I interpreted as beign a problem with
the disk format, I think the error message dialog said something like, "This
should never happen." Then after hitting OK or whatever to get out of the error
dialog the installer crashed with an unhandled exception.

I don't remember where the unhandled exception was with the first set of disks I
made came at, but the end result was a similar unhandled exception.

In both sets of disks, the media test failed.

I created the first set of disks using CDBurnerXP Pro v3. The second time
around, I tried using the same program but on a different computer. The result
was the same, so i downloaded a tool that allows you to burn ISOs using the
built in XP burning functionality. The tool is called "ISO Recorder."

I don't think this is a problem with anaconda, but there was no "Install Media"
option and the guided bug creation process said to use Anaconda for all install
related problems.
Comment 3 David Cantrell 2006-01-18 10:46:58 EST
This doesn't sound like a problem with the media.  If it boots and the installer
loads, you probably have good media.  What it sounds like is a hardware problem
or a condition that our installer is not handling properly.

Can you provide more information about the type of system, the disks you want to
partition, and how they are attached to the system.

Perform the autopartition step again, but select the option to review the layout
before continuing.  What layout has it created?

One last question...I just noticed the Fedora version reported is fc4.  Are you
trying to install fc4 or fc5t2?
Comment 4 Matthew Nuzum 2006-01-18 13:51:15 EST
FC4

A quick test to see if this is a problem isolated to me is to download the ISOs
from a mirror or Torrent and try to use them. If it works, then this is likely
not a bug. If it fails, then someone needs to do something serious...

I cannot perform the tests again because the system is now up and running with
Ubuntu (I couldn't wait any longer).

BUT if the disks weren't bad, then why did the media test fail? It failed for
every disk and at different points of the media test. (i.e. disk 1 failed at
14%, disk 2 failed at a 85%... these are aproximate numbers)
Comment 5 David Cantrell 2006-01-18 13:56:31 EST
Ah, I thought this was with FC5 test 2 which was pushed at the beginning of this
week.  Please try installing again using FC5 test 2.  Here are the download
locations for FC5 test 2:

http://torrent.fedoraproject.org/

I'm still guessing this is a partitioning bug that was fixed in rawhide after
FC4 was released, so you'll likely not have the same problem under FC5 test 2. 
The media check mode sometimes fails when it should succeed.  Check the SHA1
digest and burn if it matches.
Comment 6 Matthew Nuzum 2006-01-18 14:12:13 EST
Someone in my office had the ISOs downloaded from a while back and has used them
and knows they're good. We compared the sha1 to the one of the files I
downloaded and it matched. That means either I encountered this partitioning bug
you mentioned or my burning process is funky.

I guess it's safe to close this bug as a duplicate to the one you've alredy fixed.
Comment 7 David Cantrell 2006-01-18 14:17:35 EST
OK, I'll go ahead and mark it as closed.  One thing I've hit before is trying to
boot CDs that I've burned in a fast burner.  I usually burn Fedora media at 4x
if I encounter problems.

Note You need to log in before you can comment on or make changes to this bug.