Bug 1780004 - Can't Download Icon Theme In Caliblre Look & Feel Window
Summary: Can't Download Icon Theme In Caliblre Look & Feel Window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 31
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-05 08:46 UTC by Rabin
Modified: 2020-01-09 01:26 UTC (History)
5 users (show)

Fixed In Version: calibre-4.8.0-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-09 01:26:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Rabin 2019-12-05 08:46:55 UTC
Description of problem:

While tring to download a new icon theme, I get this error message.



Version-Release number of selected component (if applicable):

    calibre, version 4.1.0
    ERROR: Unhandled exception: <b>TypeError</b>:'<' not supported between instances of 'QModelIndex' and 'int'

    calibre 4.1  embedded-python: False is64bit: True
    Linux-5.3.12-300.fc31.x86_64-x86_64-with-fedora-31-Thirty_One Linux ('64bit', 'ELF')
    ('Linux', '5.3.12-300.fc31.x86_64', '#1 SMP Thu Nov 21 22:52:07 UTC 2019')
    Python 3.7.5
    Linux: ('Fedora', '31', 'Thirty One')
    Interface language: None
    Successfully initialized third party plugins: EpubMerge (2, 6, 0) && Ex Libris (1, 0, 19) && Wiki Reader (2, 1, 0)
    Traceback (most recent call last):
      File "/usr/lib64/calibre/calibre/gui2/icon_theme.py", line 743, in accept
        if self.theme_list.currentIndex() < 0:
    TypeError: '<' not supported between instances of 'QModelIndex' and 'int'



How reproducible:



Steps to Reproduce:

 Under perferance > look & feel > download a icon theme

Actual results:

 above error

Expected results:

 download the icon theme

Additional info:

 If i comment out the above line which check if a list item is select
 the download works. but then there is another error when trying to apply the 
 theme.

    Traceback (most recent call last):
      File "/usr/lib64/calibre/calibre/gui2/preferences/main.py", line 409, in accept
        close = self.commit()
      File "/usr/lib64/calibre/calibre/gui2/preferences/main.py", line 370, in commit
        must_restart = self.showing_widget.commit()
      File "/usr/lib64/calibre/calibre/gui2/preferences/look_feel.py", line 772, in commit
        self.commit_icon_theme()
      File "/usr/lib64/calibre/calibre/gui2/icon_theme.py", line 789, in commit_changes
        install_icon_theme(theme, f)
      File "/usr/lib64/calibre/calibre/gui2/icon_theme.py", line 847, in install_icon_theme
        json.dump(theme, buf, indent=2)
      File "/usr/lib64/python3.7/json/__init__.py", line 180, in dump
        fp.write(chunk)
    TypeError: a bytes-like object is required, not 'str'

Comment 1 Rabin 2019-12-05 08:58:02 UTC
Seems to be resolved in version 4.5 which in the testing repo right now.
but the 2nd error still happen when clicking "Apply" button.

Comment 2 Kevin Fenzi 2019-12-19 18:57:02 UTC
Would you be willing to file this upstream at launchpad.net/calibre ? or would you prefer I do so?

Comment 3 Kevin Fenzi 2019-12-19 19:06:23 UTC
Actuallly, nevermind. This seems to be fixed in 4.6.0 which should be coming to updates-testing later today. :)

Comment 4 Fedora Update System 2019-12-19 19:58:39 UTC
FEDORA-2019-6fe6a69605 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6fe6a69605

Comment 5 Fedora Update System 2019-12-20 02:11:16 UTC
calibre-4.6.0-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6fe6a69605

Comment 6 Rabin 2019-12-21 19:53:44 UTC
works for me, thanks,
added karma.

Comment 7 Fedora Update System 2020-01-04 22:22:48 UTC
analitza-19.08.3-2.fc31, appmenu-qt5-0.3.0+16.10.20160628.1-19.fc31, calibre-4.8.0-1.fc31, deepin-editor-1.2.9.1-3.fc31, deepin-file-manager-5.0.0-4.fc31, deepin-kwin-0.1.0-4.fc31, deepin-launcher-5.0.0-3.fc31, deepin-qt-dbus-factory-5.0.1-3.fc31, deepin-qt5dxcb-plugin-5.0.1-3.fc31, deepin-qt5integration-5.0.0-3.fc31, dnscrypt-proxy-gui-1.21.16-9.fc31, dtkwidget-2.1.1-3.fc31, dtkwm-2.0.12-3.fc31, elisa-player-19.12.0-2.fc31, fcitx-qt5-1.2.4-2.fc31, gammaray-2.11.0-4.fc31, gcin-2.8.9-2.fc31, hedgewars-1.0.0-3.fc31, kf5-akonadi-server-19.04.3-4.fc31, kf5-frameworkintegration-5.64.0-2.fc31, kf5-kdeclarative-5.64.0-2.fc31, kf5-kwayland-5.64.0-2.fc31, kf5-kxmlgui-5.64.0-2.fc31, kmymoney-5.0.7-2.fc31, kwin-5.17.4-2.fc31, libalkimia-8.0.2-1.fc31, libfm-qt-0.14.1-8.fc31, libqtxdg-3.3.1-7.fc31, lumina-desktop-1.5.0-3.fc31, lxqt-qtplugin-0.14.0-7.fc31, mscore-3.3.4-4.fc31, plasma-integration-5.17.4-2.fc31, pyotherside-1.5.8-6.fc31, python-pyside2-5.13.2-1.fc31, python-qt5-5.13.2-3.fc31, qgis-3.10.1-2.fc31, qgnomeplatform-0.6.0-2.fc31, qstardict-1.3-14.fc31, qt-creator-4.10.2-3.fc31, qt5-5.13.2-1.fc31, qt5-qt3d-5.13.2-1.fc31, qt5-qtbase-5.13.2-1.fc31, qt5-qtcanvas3d-5.12.5-2.fc31, qt5-qtcharts-5.13.2-1.fc31, qt5-qtconnectivity-5.13.2-1.fc31, qt5-qtdatavis3d-5.13.2-1.fc31, qt5-qtdeclarative-5.13.2-1.fc31, qt5-qtdoc-5.13.2-1.fc31, qt5-qtenginio-1.6.2-27.fc31, qt5-qtgamepad-5.13.2-1.fc31, qt5-qtgraphicaleffects-5.13.2-1.fc31, qt5-qtimageformats-5.13.2-1.fc31, qt5-qtlocation-5.13.2-1.fc31, qt5-qtmultimedia-5.13.2-1.fc31, qt5-qtnetworkauth-5.13.2-1.fc31, qt5-qtquickcontrols-5.13.2-1.fc31, qt5-qtquickcontrols2-5.13.2-1.fc31, qt5-qtremoteobjects-5.13.2-1.fc31, qt5-qtscript-5.13.2-1.fc31, qt5-qtscxml-5.13.2-1.fc31, qt5-qtsensors-5.13.2-1.fc31, qt5-qtserialbus-5.13.2-1.fc31, qt5-qtserialport-5.13.2-1.fc31, qt5-qtspeech-5.13.2-1.fc31, qt5-qtstyleplugins-5.0.0-37.fc31, qt5-qtsvg-5.13.2-1.fc31, qt5-qttools-5.13.2-3.fc31, qt5-qttranslations-5.13.2-1.fc31, qt5-qtvirtualkeyboard-5.13.2-1.fc31, qt5-qtwayland-5.13.2-2.fc31, qt5-qtwebchannel-5.13.2-1.fc31, qt5-qtwebengine-5.13.2-1.fc31, qt5-qtwebkit-5.212.0-0.41.alpha3.fc31, qt5-qtwebsockets-5.13.2-1.fc31, qt5-qtwebview-5.13.2-1.fc31, qt5-qtx11extras-5.13.2-1.fc31, qt5-qtxmlpatterns-5.13.2-1.fc31, qt5ct-0.38-7.fc31, qtcurve-1.9.1-9.fc31, skrooge-2.20.0-4.fc31, texmaker-5.0.3-7.fc31, ugene-33.0-11.fc31, xdg-desktop-portal-kde-5.17.4-2.fc31, yarock-1.4.0-6.fc31, yubioath-desktop-5.0.1-3.gitc58db92.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-1571a44ff7

Comment 8 Fedora Update System 2020-01-09 01:26:51 UTC
analitza-19.08.3-2.fc31, appmenu-qt5-0.3.0+16.10.20160628.1-19.fc31, calibre-4.8.0-1.fc31, deepin-editor-1.2.9.1-3.fc31, deepin-file-manager-5.0.0-4.fc31, deepin-kwin-0.1.0-4.fc31, deepin-launcher-5.0.0-3.fc31, deepin-qt-dbus-factory-5.0.1-3.fc31, deepin-qt5dxcb-plugin-5.0.1-3.fc31, deepin-qt5integration-5.0.0-3.fc31, dnscrypt-proxy-gui-1.21.16-9.fc31, dtkwidget-2.1.1-3.fc31, dtkwm-2.0.12-3.fc31, elisa-player-19.12.0-2.fc31, fcitx-qt5-1.2.4-2.fc31, gammaray-2.11.0-4.fc31, gcin-2.8.9-2.fc31, hedgewars-1.0.0-3.fc31, kf5-akonadi-server-19.04.3-4.fc31, kf5-frameworkintegration-5.64.0-2.fc31, kf5-kdeclarative-5.64.0-2.fc31, kf5-kwayland-5.64.0-2.fc31, kf5-kxmlgui-5.64.0-2.fc31, kmymoney-5.0.7-2.fc31, kwin-5.17.4-2.fc31, libalkimia-8.0.2-1.fc31, libfm-qt-0.14.1-8.fc31, libqtxdg-3.3.1-7.fc31, lumina-desktop-1.5.0-3.fc31, lxqt-qtplugin-0.14.0-7.fc31, mscore-3.3.4-4.fc31, plasma-integration-5.17.4-2.fc31, pyotherside-1.5.8-6.fc31, python-pyside2-5.13.2-1.fc31, python-qt5-5.13.2-3.fc31, qgis-3.10.1-2.fc31, qgnomeplatform-0.6.0-2.fc31, qstardict-1.3-14.fc31, qt-creator-4.10.2-3.fc31, qt5-5.13.2-1.fc31, qt5-qt3d-5.13.2-1.fc31, qt5-qtbase-5.13.2-1.fc31, qt5-qtcanvas3d-5.12.5-2.fc31, qt5-qtcharts-5.13.2-1.fc31, qt5-qtconnectivity-5.13.2-1.fc31, qt5-qtdatavis3d-5.13.2-1.fc31, qt5-qtdeclarative-5.13.2-1.fc31, qt5-qtdoc-5.13.2-1.fc31, qt5-qtenginio-1.6.2-27.fc31, qt5-qtgamepad-5.13.2-1.fc31, qt5-qtgraphicaleffects-5.13.2-1.fc31, qt5-qtimageformats-5.13.2-1.fc31, qt5-qtlocation-5.13.2-1.fc31, qt5-qtmultimedia-5.13.2-1.fc31, qt5-qtnetworkauth-5.13.2-1.fc31, qt5-qtquickcontrols-5.13.2-1.fc31, qt5-qtquickcontrols2-5.13.2-1.fc31, qt5-qtremoteobjects-5.13.2-1.fc31, qt5-qtscript-5.13.2-1.fc31, qt5-qtscxml-5.13.2-1.fc31, qt5-qtsensors-5.13.2-1.fc31, qt5-qtserialbus-5.13.2-1.fc31, qt5-qtserialport-5.13.2-1.fc31, qt5-qtspeech-5.13.2-1.fc31, qt5-qtstyleplugins-5.0.0-37.fc31, qt5-qtsvg-5.13.2-1.fc31, qt5-qttools-5.13.2-3.fc31, qt5-qttranslations-5.13.2-1.fc31, qt5-qtvirtualkeyboard-5.13.2-1.fc31, qt5-qtwayland-5.13.2-2.fc31, qt5-qtwebchannel-5.13.2-1.fc31, qt5-qtwebengine-5.13.2-1.fc31, qt5-qtwebkit-5.212.0-0.41.alpha3.fc31, qt5-qtwebsockets-5.13.2-1.fc31, qt5-qtwebview-5.13.2-1.fc31, qt5-qtx11extras-5.13.2-1.fc31, qt5-qtxmlpatterns-5.13.2-1.fc31, qt5ct-0.38-7.fc31, qtcurve-1.9.1-9.fc31, skrooge-2.20.0-4.fc31, texmaker-5.0.3-7.fc31, ugene-33.0-11.fc31, xdg-desktop-portal-kde-5.17.4-2.fc31, yarock-1.4.0-6.fc31, yubioath-desktop-5.0.1-3.gitc58db92.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.