Bug 178002 - Afrikaans myspell dictionary in OpenOffice.org has broken suggestions
Afrikaans myspell dictionary in OpenOffice.org has broken suggestions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 02:46 EST by Dwayne Bailey
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 04:56:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwayne Bailey 2006-01-17 02:46:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When spell checking using the Afrikaans Myspell spell checker any suggested spellings contain broken characters.  The errors looks as if it is displaying UTF-8 characters in ISO-8859-1.

On investigation the file:
/usr/lib/openoffice.org2.0/share/dict/ooo/af_ZA.dic
is encoded using UTF-8.

This file should be in ISO-8859-1

Version-Release number of selected component (if applicable):
openoffice.org-langpack-af_ZA-2.0.1.1-4.1

How reproducible:
Always

Steps to Reproduce:
1. Install openoffice.org-langpack-af_ZA-2.0.1.1-4.1
2. Using OpenOffice.org type the following word: geirriteer
3. Select the word
4. Format->Character - change the text to Afrikaans
5. Word should be misspelled.  Now right click and view suggestions.
  

Actual Results:  The following suggestions appear in the list:
ge�riteer
...

Expected Results:  This word should be displayed:
ge�rriteer

Additional info:
Comment 1 Caolan McNamara 2006-01-17 04:49:36 EST
A newer upstream dictionary is available. I'll include that instead
Comment 2 Caolan McNamara 2006-01-26 04:56:12 EST
fixed in rawhide, will be backported when there is a future respin for FC-4

Note You need to log in before you can comment on or make changes to this bug.