Bug 1780039 - dstat does not average over $delay interval anymore
Summary: dstat does not average over $delay interval anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcp
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nathan Scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-05 09:50 UTC by Georg Sauthoff
Modified: 2020-03-16 20:29 UTC (History)
4 users (show)

Fixed In Version: pcp-5.0.3 pcp-5.0.3-2.fc31 pcp-5.0.3-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-11 22:45:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Georg Sauthoff 2019-12-05 09:50:16 UTC
Description of problem:
Since dstat is provided by pcp (pcp-system-tools), the tool doesn't average the values over the $delay interval, anymore. This is a regression over the traditional dstat.

If you specify a delay of 60 seconds (e.g. `dstat 60`) dstat used to display up-to-date average for the current interval (i.e. updating each second, average over the started interval, so far), and each finished delay row would list the average values over that complete interval. Also, dstat used slightly different colors to indicate the updating current row.

This feature is very useful because especially for 'jumpy' metrics you get a better overview with a delay greater than 1 second and averaging.

The current pcp dstat does nothing of that. Instead it seems that a delay interval row just contains the last observed values. Even when the interval is finished and a new interval row is started.

Version-Release number of selected component (if applicable):
pcp-system-tools-5.0.1-1.fc31.x86_64

How reproducible:
always

Steps to Reproduce:
1. dstat 60
2. trigger 100 MB/s disk read/write for the next 30 seconds
3.

Actual results:
You did not select any stats, using -cdngy by default.
----total-usage---- -dsk/total- -net/total- ---paging-- ---system--
usr sys idl wai stl| read  writ| recv  send|  in   out | int   csw 
  3   1  96   0   0|  16k    0 |   0     0 |   0     0 | 620  1403 
  2   2  96   0   0|   0     0 |   0     0 |   0     0 | 585  1455


Expected results:
The average of ~ 50 in the dsk/total columns.


Additional info:

Comment 1 Nathan Scott 2019-12-05 23:04:59 UTC
Hmm yes indeed - this looks like an unintended change in behaviour.  I'll look into it, though possibly not for a few weeks with holidays coming up (patches welcome in the meantime).

Comment 2 Nathan Scott 2020-01-13 04:37:42 UTC
commit 67a19e3533e4f71721ee8839265b7221274db2e5
Author: Nathan Scott <nathans>
Date:   Mon Jan 13 15:27:01 2020 +1100

    dstat: perform sub-sample averaging over the delay window
    
    Resolves Red Hat bugzilla #1780039

Comment 3 Fedora Update System 2020-02-27 11:25:59 UTC
FEDORA-2020-1948419b2e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1948419b2e

Comment 4 Fedora Update System 2020-02-27 18:38:15 UTC
pcp-5.0.3-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1948419b2e

Comment 5 Fedora Update System 2020-02-28 01:27:29 UTC
pcp-5.0.3-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7ac95d60db

Comment 6 Fedora Update System 2020-03-02 05:27:52 UTC
FEDORA-2020-a4236a5dcf has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a4236a5dcf

Comment 7 Fedora Update System 2020-03-02 19:56:52 UTC
pcp-5.0.3-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a4236a5dcf

Comment 8 Fedora Update System 2020-03-11 22:45:52 UTC
pcp-5.0.3-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-03-16 20:16:56 UTC
pcp-5.0.3-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2020-03-16 20:29:38 UTC
pcp-5.0.3-1.fc32 has been pushed to the Fedora 32 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.