Bug 1780066 - did: bad format if the output is forwarded to a pipe or a file
Summary: did: bad format if the output is forwarded to a pipe or a file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: did
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Petr Šplíchal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-05 10:49 UTC by Dalibor Pospíšil
Modified: 2019-12-19 01:23 UTC (History)
2 users (show)

Fixed In Version: did-0.16-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-19 01:23:08 UTC


Attachments (Terms of Use)

Description Dalibor Pospíšil 2019-12-05 10:49:57 UTC
Description of problem:
$ did --since 2019-11-18 --until 2019-11-24 | cat -
b'Status report for given date range (2019-11-04 to 2019-11-10).'
b'\n~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\n Dalibor Pospisil <dapospis@redhat.com>\n~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~'

b'* Errata completed: 2'
...

Version-Release number of selected component (if applicable):
did-0.15-1.fc30.noarch

How reproducible:
100%

Expected results:
the output is formatted the same as if it goes to stdout

Comment 1 Petr Šplíchal 2019-12-05 12:18:44 UTC
This has been already reported and fixed upstream:
https://github.com/psss/did/issues/211
Fedora update coming soon.

Comment 2 Petr Šplíchal 2019-12-05 12:20:22 UTC
https://github.com/psss/did/commit/a0f514e

Comment 3 Fedora Update System 2019-12-10 12:21:02 UTC
FEDORA-2019-3059241680 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3059241680

Comment 4 Fedora Update System 2019-12-11 01:41:45 UTC
did-0.16-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3059241680

Comment 5 Fedora Update System 2019-12-19 01:23:08 UTC
did-0.16-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.