Bug 1780125 - no_proxy system property incorrectly generated
Summary: no_proxy system property incorrectly generated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: jawed
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On: 1776760
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-05 13:15 UTC by Akram Ben Aissi
Modified: 2020-10-27 15:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1776760
Environment:
Last Closed: 2020-10-27 15:54:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift jenkins pull 1078 0 None closed Bug 1780125: fix proxy settings in jenkins 2021-02-11 14:05:25 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:55:08 UTC

Comment 2 XiuJuan Wang 2020-01-19 07:07:57 UTC
In the gcp with http proxy cluster 4.4.0-0.nightly-2020-01-17-032851
Could access jenkins webconsole, but there are some error in pod log, http://pastebin.test.redhat.com/828241

And in aws with proxy cluster, 4.4.0-0.nightly-2020-01-17-032851
Can't access jenkins webconsole, with the similar error http://pastebin.test.redhat.com/828250

Comment 3 Akram Ben Aissi 2020-03-12 21:08:54 UTC
This is not a bug actually, but it requires documentation update.
Moving it to 4.5 as it is not a blocker.

Comment 4 Akram Ben Aissi 2020-03-12 21:15:46 UTC
TO BE ADDED TO DOCUMENTATION 

we have done some tests with it today and gathered information for the MCO team. They said they will not support and they will not implement propagation of http_proxy configuration from cluster-wide proxy configuration to user applications.

So, for make this to work, you need to setup http_proxy, https_proxy and no_proxy in your deployment config to make it work.
We have done it using the following command:

```
oc set env dc/jenkins http_proxy=$(oc get proxy cluster -o jsonpath='{.status.httpProxy}') \
                      https_proxy=$(oc get proxy cluster -o jsonpath='{.status.httpsProxy}') \
                      no_proxy=$(oc get proxy cluster -o jsonpath='{.status.noProxy}') 
```

So, we will update the documentation and link it to this BZ. Could you please confirm that setting the environment variables works?
and if yes, do not mark this issue as a blocker, as it will be documentation only.

Comment 6 jawed 2020-06-09 15:02:32 UTC
no_proxy should be set like this
oc set env dc/jenkins no_proxy=".svc,*.svc.cluster.*,*.svc.cluster.local,172.30.*,kubernetes.default,10.0.*"
and not from this
oc set env dc/jenkins no_proxy=$(oc get proxy cluster -o jsonpath='{.status.noProxy}')

Comment 9 XiuJuan Wang 2020-07-07 02:37:10 UTC
Pending on 4.6 proxy cluster installtaion.
When qe gets a proxy cluster, will verify this bug.

Comment 10 XiuJuan Wang 2020-07-14 06:28:44 UTC
Could access jenkins webconsole after set env like below.

$oc set env dc/jenkins http_proxy=$(oc get proxy cluster -o jsonpath='{.status.httpProxy}') \
                      https_proxy=$(oc get proxy cluster -o jsonpath='{.status.httpsProxy}') \
                      no_proxy=".svc,*.svc.cluster.*,*.svc.cluster.local,172.30.*,kubernetes.default,10.0.*"

Verified on 4.6.0-0.nightly-2020-07-13-22420 proxy cluster

Comment 12 errata-xmlrpc 2020-10-27 15:54:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.