Bug 1780190 - glfsheal should be installed and invoked as architecture-dependent binary helper
Summary: glfsheal should be installed and invoked as architecture-dependent binary helper
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-05 14:43 UTC by Dmitry Antipov
Modified: 2019-12-19 11:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-19 11:12:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 23817 None Merged glfsheal: install as architecture-dependent binary helper 2019-12-19 11:12:21 UTC
Red Hat Bugzilla 1776784 unspecified CLOSED glfsheal crash on unexpected volume name 2019-12-10 06:30:05 UTC

Description Dmitry Antipov 2019-12-05 14:43:31 UTC
Since glfsheal is a binary helper which is not intented to be invoked directly, it should be installed to (and invoked from) %{libexecdir}/glusterfs rather
than %{sbindir}.

Comment 1 Worker Ant 2019-12-05 14:57:41 UTC
REVIEW: https://review.gluster.org/23817 (glfsheal: install as architecture-dependent binary helper) posted (#1) for review on master by None

Comment 2 Sahina Bose 2019-12-09 08:26:21 UTC
Ravi, assigning to you to follow-up

Comment 3 Ravishankar N 2019-12-17 10:41:31 UTC
Dmitry, not sure if you are getting the gerrit notifications but do you want to refresh your patch to address Niels's comment?

Comment 4 Dmitry Antipov 2019-12-17 11:01:31 UTC
(In reply to Ravishankar N from comment #3)
> Dmitry, not sure if you are getting the gerrit notifications but do you want
> to refresh your patch to address Niels's comment?

Updated.

Comment 5 Worker Ant 2019-12-19 11:12:23 UTC
REVIEW: https://review.gluster.org/23817 (glfsheal: install as architecture-dependent binary helper) merged (#3) on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.