Bug 1780327 - most of links from API explorer are broken
Summary: most of links from API explorer are broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Lukasz Szaszkiewicz
QA Contact: Xingxing Xia
URL:
Whiteboard:
: 1789267 (view as bug list)
Depends On:
Blocks: 1795704
TreeView+ depends on / blocked
 
Reported: 2019-12-05 17:16 UTC by jooho lee
Modified: 2020-01-30 07:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1795704 (view as bug list)
Environment:
Last Closed: 2020-01-30 07:41:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jooho lee 2019-12-05 17:16:54 UTC
Description of problem:
API explorer page has a bunch of wrong links 

(Example)
https://git.k8s.io/community/contributors/devel/api-conventions.md#spec-and-status

==> result in 404 pages.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Go webconsole console
2.Click explorer
3.Click any of objects


Actual results:
Links are broken.

Expected results:
Links show a right page.

Additional info:

Comment 1 Samuel Padgett 2019-12-05 19:08:30 UTC
This isn't specific to console and happens with `oc explain` as well. The links in the API doc itself are broken. Looks like the pages moved in the community repo.

Comment 2 Lukasz Szaszkiewicz 2020-01-08 09:47:59 UTC
The link to the api-conventions doc is part of the API types definition, for example, https://github.com/openshift/origin/blob/release-4.2/vendor/k8s.io/kubernetes/staging/src/k8s.io/api/core/v1/types.go#L3179
 
To fix the link we would have to identify every occurrence of it in all types and regenerate the swagger spec.
Additionally, we would have check if the other links are not outdated too.

This seems to be only broken in 4.2 (4.3 and 4.4 look good).

Comment 3 Samuel Padgett 2020-01-09 21:19:00 UTC
*** Bug 1789267 has been marked as a duplicate of this bug. ***

Comment 4 Lukasz Szaszkiewicz 2020-01-28 16:47:37 UTC
@Xingxing please close it as this bug only affects 4.2.


Note You need to log in before you can comment on or make changes to this bug.