Bug 1780376 - Service Account Pull Secrets Include IPv6 Addresses
Summary: Service Account Pull Secrets Include IPv6 Addresses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.3.0
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Adam Kaplan
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks: 1784569
TreeView+ depends on / blocked
 
Reported: 2019-12-05 20:05 UTC by Adam Kaplan
Modified: 2020-05-04 11:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1784569 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:18:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-controller-manager pull 52 'None' closed Bug 1780376: Exclude IPv6 Registry Locations 2020-04-17 17:48:50 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:19:10 UTC

Description Adam Kaplan 2019-12-05 20:05:38 UTC
Description of problem:

The pull secret for the internal registry associated with each service account includes the ClusterIP address of the registry service. This is invalid if the cluster is using IPv6 addresses.

Version-Release number of selected component (if applicable): 4.3.0


How reproducible: Always


Steps to Reproduce:
1. Deploy OCP in an IPv6 cluster
2. Create a project
3. Decode the dockercfg secret associated with the project's default and builder service accounts

Actual results:

Pull secret includes a registry location that has an IPv6 address.


Expected results:

Pull secret should not have IPv6 address locations. IPv6 addresses are not supported locations in an image pull spec.


Additional info:

Comment 1 Adam Kaplan 2019-12-05 20:08:53 UTC
Target 4.4.0. Per eparis will need a backport to 4.3.z.

Comment 3 Russell Bryant 2020-01-28 22:03:15 UTC
I successfully tested this change

Comment 5 errata-xmlrpc 2020-05-04 11:18:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.