Bug 1780781 - xorgxrdp has broken xorg-x11-server-Xorg dependency on fedora-30 (Dec 6, 2019)
Summary: xorgxrdp has broken xorg-x11-server-Xorg dependency on fedora-30 (Dec 6, 2019)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorgxrdp
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Roskin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-06 22:04 UTC by Ben Greear
Modified: 2020-01-19 00:35 UTC (History)
3 users (show)

Fixed In Version: xorgxrdp-0.2.12-4.fc30 xorgxrdp-0.2.12-2.fc31 xorgxrdp-0.2.12-2.el8 xorgxrdp-0.2.12-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-12 01:16:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Ben Greear 2019-12-06 22:04:40 UTC
Description of problem:

[root@localhost ]# dnf install xorgxrdp
Last metadata expiration check: 0:09:41 ago on Fri 06 Dec 2019 01:48:26 PM PST.
Dependencies resolved.

 Problem: cannot install the best candidate for the job
  - nothing provides xorg-x11-server-Xorg(x86-64) = 1.20.6 needed by xorgxrdp-0.2.11-2.fc30.x86_64
====================================================================================================
 Package                        Architecture     Version     Repository         Size
====================================================================================================
Installing:
 xorgxrdp                       x86_64           0.2.9-3.fc30     fedora             63 k
Downgrading:
 xorg-x11-server-Xorg           x86_64           1.20.4-3.fc30     fedora            1.4 M
Skipping packages with broken dependencies:
 xorgxrdp                       x86_64           0.2.11-2.fc30     updates            69 k

Transaction Summary
====================================================================================================
Install    1 Package
Downgrade  1 Package
Skip       1 Package

Total download size: 1.5 M 
Version-Release number of selected component (if applicable):


How reproducible:

Always as of today, but this worked a few weeks ago.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Bojan Smojver 2019-12-06 22:38:20 UTC
Please +1 this, so that it gets into stable:

https://bodhi.fedoraproject.org/updates/FEDORA-2019-ed226e6112

Comment 2 Ben Greear 2019-12-09 22:00:19 UTC
We tested the update:  https://bodhi.fedoraproject.org/updates/FEDORA-2019-0e9a61f3a6
and it seems to work fine.  Please promote that to stable.

Comment 3 Bojan Smojver 2019-12-11 11:24:06 UTC
If you give +1 to xorg-x11-server-1.20.6-1.fc30 in bodhi, that will get pushed to stable.

Comment 4 Ben Greear 2019-12-11 17:08:35 UTC
Maybe you can +1 it?  I don't have an account on the fedora page

Comment 5 Bojan Smojver 2019-12-11 20:14:19 UTC
(In reply to Ben Greear from comment #4)
> Maybe you can +1 it?  I don't have an account on the fedora page

I use F31 right now, so I didn't test it. Whoever tests the package should give karma in bodhi.

Comment 6 Fedora Update System 2020-01-03 20:37:38 UTC
FEDORA-2020-4cc57c1cc9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4cc57c1cc9

Comment 7 Fedora Update System 2020-01-03 20:37:39 UTC
FEDORA-2020-61786117f7 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-61786117f7

Comment 8 Fedora Update System 2020-01-03 20:37:41 UTC
FEDORA-EPEL-2020-7f62b9c67c has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7f62b9c67c

Comment 9 Fedora Update System 2020-01-03 20:37:41 UTC
FEDORA-EPEL-2020-7dc6a9e9e5 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7dc6a9e9e5

Comment 10 Fedora Update System 2020-01-04 20:24:27 UTC
xorgxrdp-0.2.12-2.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7dc6a9e9e5

Comment 11 Fedora Update System 2020-01-04 20:35:46 UTC
xorgxrdp-0.2.12-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7f62b9c67c

Comment 12 Fedora Update System 2020-01-04 21:18:36 UTC
xorgxrdp-0.2.12-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-61786117f7

Comment 13 Fedora Update System 2020-01-04 22:24:49 UTC
xorgxrdp-0.2.12-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4cc57c1cc9

Comment 14 Fedora Update System 2020-01-12 01:16:02 UTC
xorgxrdp-0.2.12-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2020-01-12 01:42:57 UTC
xorgxrdp-0.2.12-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Ben Greear 2020-01-13 03:56:50 UTC
It looks like this is still broken?

# dnf install xorgxrdp
Fedora Modular 30 - x86_64                                                                                         1.8 MB/s | 2.7 MB     00:01    
Fedora Modular 30 - x86_64 - Updates                                                                               3.5 MB/s | 4.0 MB     00:01    
Fedora 30 - x86_64 - Updates                                                                                       5.3 MB/s |  23 MB     00:04    
Fedora 30 - x86_64                                                                                                  11 MB/s |  70 MB     00:06    
Dependencies resolved.

 Problem: cannot install the best candidate for the job
  - nothing provides xorg-x11-server-Xorg(x86-64) = 1.20.6 needed by xorgxrdp-0.2.12-4.fc30.x86_64
===================================================================================================================================================
 Package                                    Architecture                 Version                               Repository                     Size
===================================================================================================================================================
Installing:
 xorgxrdp                                   x86_64                       0.2.9-3.fc30                          fedora                         63 k
Downgrading:
 xorg-x11-server-Xorg                       x86_64                       1.20.4-3.fc30                         fedora                        1.4 M
Skipping packages with broken dependencies:
 xorgxrdp                                   x86_64                       0.2.12-4.fc30                         updates                        70 k

Transaction Summary
===================================================================================================================================================
Install    1 Package
Downgrade  1 Package
Skip       1 Package

Total download size: 1.5 M

Comment 17 Bojan Smojver 2020-01-13 05:42:28 UTC
Please +1 this, so that it gets into stable:

https://bodhi.fedoraproject.org/updates/FEDORA-2019-ed226e6112

Comment 18 Fedora Update System 2020-01-19 00:19:48 UTC
xorgxrdp-0.2.12-2.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2020-01-19 00:35:29 UTC
xorgxrdp-0.2.12-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.