Bug 178079 - NVRAID array recognized and installed to by installer, but not bootloader
NVRAID array recognized and installed to by installer, but not bootloader
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-01-17 13:52 EST by Dan Book
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: FC5 (mkinitrd-5.0.32-1)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 02:18:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Book 2006-01-17 13:52:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Galeon/2.0.0

Description of problem:
I installed FC5 test 2 on my NVRAID 0 array, and the installation went smoothly. However, upon attempting to boot, I somehow was sent into the grub prompt. There I noticed that (hd0) was set to my RAID array and not (hd1) as the grub.conf created by the installer was set to. I corrected this and attempted to boot again, but the bootloader could not find any files, including the splash screen graphic. Thus, it appears dmraid is not loaded in time for grub to see the array.

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc9-FC5_4.1

How reproducible:
Always

Steps to Reproduce:
1. Install FC5 test 2 on an NVRAID array.
2. Attempt to boot it.
  

Actual Results:  Cannot find the files to boot linux, or the partition to boot windows from.

Expected Results:  Successful boot.

Additional info:
Comment 1 Dan Book 2006-01-17 17:18:17 EST
The first time, I changed (hd1) to point to the RAID array, but apparently it
still used (hd0). So, I then changed the grub.conf created by the installer to
point to (hd0) instead of (hd1) each time, and am now able to boot Windows.
However, booting FC5 results in a kernel panic.
Comment 2 Dan Book 2006-01-17 17:21:12 EST
I am not sure if dmraid is still part of the issue, I think it's mostly
anaconda, but it's a slightly different issue than I initially thought.
Comment 3 Dan Book 2006-01-17 17:37:06 EST
However, I am unsure why the grub prompt comes up on the first boot; it
obviously installed something or the bootloader would still be what I had
previously installed, but once I install grub manually it works fine (grub does,
not FC5).
Comment 4 Heinz Mauelshagen 2006-01-18 06:25:29 EST
Changing to ananconda, because it needs to prevent installation on RAID0 which
grub can't boot off.
Comment 5 Dan Book 2006-01-18 12:31:10 EST
I beg to differ, I had grub booting FC4 off RAID 0 just before I installed FC5
test 2. See my guide: http://www.fedorasolved.com/viewtopic.php?t=154 and the
guide I used: http://www.spinics.net/lists/ataraid/msg02310.html
Note this is NVRAID 0, not linux RAID 0.
Comment 6 Dan Book 2006-01-18 12:40:14 EST
Also, it should still be able to install on linux RAID 0, just not the /boot
partition, correct?
Comment 7 Alexey 2006-01-19 13:58:09 EST
(In reply to comment #5)
> I beg to differ, I had grub booting FC4 off RAID 0 just before I installed FC5
> test 2. See my guide: http://www.fedorasolved.com/viewtopic.php?t=154 and the
> guide I used: http://www.spinics.net/lists/ataraid/msg02310.html
> Note this is NVRAID 0, not linux RAID 0.

+1, please implement booting from NVRAID, especially because it is known how to 
do. I've got the same configuration as bug reporter only I got kernel panic when 
booting right from the beginning (unable to mount root partition). Will try to 
rebuild initrd now and see if it helps.
Comment 8 Dan Book 2006-01-26 12:58:04 EST
Just curious if anyone is looking into making this work. Don't think it would be
too much work; I hope not.
Comment 9 Dan Book 2006-02-13 14:22:25 EST
I would like to point out that grub itself seems to be having no issues with
dmraid whatsoever (once it is manually installed), but the initrd doesn't seem
to initialize it; it can't find the partitions to mount, using either labels or
/dev/dm.
Comment 10 Rahul Sundaram 2006-02-20 06:08:39 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 11 Dan Book 2006-02-21 16:01:02 EST
Test 3 didn't even get as far as Test 2; partially because my new video card
appears to not be supported by the default video driver (I restored my FC4
backup and still had problems, until I updated to the latest nvidia driver).
However, Grub didn't even install, and installing it manually apparently didn't
work; it's not initializing dmraid at all anymore, from what I can tell.
Thankfully, my FC4 backup system is still able to install a grub that loads
dmraid (as is FC5t2), and FC4 still loads flawlessly from it (though not from
FC5t2's grub oddly).
Comment 12 Peter Jones 2006-03-20 16:12:01 EST
Can you try this on the final FC5 tree?  It works on my nvraid test box without
any failure whatsoever.
Comment 13 Dan Book 2006-03-21 02:18:59 EST
Installed with text install (had to temporarily unplug my backup IDE drives, or
it tried to install the bootloader on that MBR, don't know why, and couldn't
change it in text mode), and booted flawlessly! Thanks very very very much, I
did not expect this to be done for FC5's release. Now just the issue of my video
card and the nv driver...

Note You need to log in before you can comment on or make changes to this bug.