Bug 178092 - Bad feedback for non-matching passwords
Bad feedback for non-matching passwords
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-17 14:48 EST by Christopher Aillon
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 12:03:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
password entry example (13.89 KB, image/png)
2006-01-18 13:44 EST, Bryan W Clark
no flags Details

  None (edit)
Description Christopher Aillon 2006-01-17 14:48:13 EST
If the passwords do not match, the user should be unable to click "Next" (the
button is desensitized).  The "Enter password" text can change to "Re-enter the
password" or something similar to let the user know that the passwords don't yet
match.
Comment 1 Jeremy Katz 2006-01-18 12:03:27 EST
Hooray for flip-flopping.

This screen used to work like that, but it was considered less discoverable for
how to get the next button to sensitize than to just let you try to click next
and then be told what the problem was.
Comment 2 Christopher Aillon 2006-01-18 13:22:55 EST
The idea is that directly underneath the two pw entry boxes, you'd have
italicized or bold text, maybe a different color or a combination of some or all
of the above which says "The two passwords do not match.  Please enter identical
passwords to proceed" or some better text.  Re-opening and CC'ing bclark and jrb
as I remember this being for HIG stuff, but can't seem to find where.
Comment 3 Bryan W Clark 2006-01-18 13:44:57 EST
Created attachment 123394 [details]
password entry example

You can see here where the 'Text telling you what to do next' is.

This text would say:
[Nothing] - when fields are empty
'Password Not Long Enough' - until password is long enough
'Please confirm password' - when password is long enough
'Passwords do not match' - until confirm password matches

Until this is all done the [Next] button should be disabled.

Note You need to log in before you can comment on or make changes to this bug.