Bug 1781011 - gnome-shell crashes with SIGSEGV in clutter_input_device_xi2_get_current_tool
Summary: gnome-shell crashes with SIGSEGV in clutter_input_device_xi2_get_current_tool
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 05:26 UTC by Yuki Okada
Modified: 2020-11-11 21:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-11 21:54:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yuki Okada 2019-12-09 05:26:07 UTC
Description of problem:
gnome-shell crashes wigh segfault.

## /var/log/messages ##
Oct 24 13:49:33 localhost journal: clutter_input_device_get_device_type: assertion 'CLUTTER_IS_INPUT_DEVICE (device)' failed
Oct 24 13:49:33 localhost kernel: gnome-shell[1877]: segfault at 128 ip 00007feeea67aaa0 sp 00007ffc3220c458 error 4 in libmutter-clutter-1.so[7feeea637000+159000]
Oct 24 13:49:33 localhost journal: clutter_input_device_get_n_axes: assertion 'CLUTTER_IS_INPUT_DEVICE (device)' failed
Oct 24 13:49:33 localhost abrt-hook-ccpp: Process 1877 (gnome-shell) of user 1000 killed by SIGSEGV - dumping core
Oct 24 13:49:37 localhost gnome-session-binary[1675]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
Oct 24 13:49:37 localhost gnome-session: gnome-session-binary[1675]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
[...]
Oct 24 13:49:43 localhost gnome-shell: GNOME Shell started at Thu Oct 24 2019 13:49:41 GMT+0900 (JST)

Backtrace shows that there is something wrong with input device handling.

$ gdb /usr/bin/gnome-shell core.1877 
[...]
Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal 11, Segmentation fault.
#0  clutter_input_device_xi2_get_current_tool (device=device@entry=0x0)
    at x11/clutter-input-device-xi2.c:292
292	  return device_xi2->current_tool;
[...]
(gdb) bt
#0  clutter_input_device_xi2_get_current_tool (device=device@entry=0x0) at x11/clutter-input-device-xi2.c:292
#1  0x00007feeea67a0c9 in clutter_device_manager_xi2_translate_event (translator=<optimized out>, native=<optimized out>, event=<optimized out>) at x11/clutter-device-manager-xi2.c:1630
#2  0x00007feeea6a2744 in clutter_backend_real_translate_event (backend=<optimized out>, native=0x7ffc3220c5c0, event=0x46be8d0) at clutter-backend.c:596
#3  0x00007feeea673ac2 in clutter_x11_handle_event (xevent=xevent@entry=0x7ffc3220c5c0) at x11/clutter-event-x11.c:200
#4  0x00007feeeb313597 in handle_host_xevent (event=0x7ffc3220c5c0, backend=0x10e40e0) at backends/x11/meta-backend-x11.c:317
#5  x_event_source_dispatch (source=<optimized out>, callback=<optimized out>, user_data=<optimized out>) at backends/x11/meta-backend-x11.c:370
#6  0x00007feee5370049 in g_main_context_prepare (context=0x0, priority=0x46be8d0) at gmain.c:3372
#7  0x00000001010e0c50 in ?? ()
#8  0x0000000000000000 in ?? ()

Version-Release number of selected component (if applicable):
gnome-shell-3.26.2-5.el7.x86_64
mutter-3.26.2-13.el7.x86_64

How reproducible:
rarely

Steps to Reproduce:
n/a

Actual results:
gnome-shell crashes

Expected results:
gnome-shell does not crash

Additional info:
The backtrace shows that this happens in input device handling. In this environment, mouse buttons (or touchscreen) sometimes stop working, and I've filed separete bug 1773815 for the issue.

Comment 2 Yuki Okada 2019-12-09 05:26:48 UTC
Similar issues are reported in Fedora or Ubuntu, but the root cause is not identified yet.

1735714 – [abrt] gnome-shell: clutter_input_device_xi2_get_current_tool(): gnome-shell killed by SIGSEGV
https://bugzilla.redhat.com/show_bug.cgi?id=1735714
Bug #1783673 “gnome-shell crashed with SIGSEGV in clutter_input_...” : Bugs : gnome-shell package : Ubuntu
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1783673

Comment 3 Chris Kaltwasser 2020-05-11 14:10:57 UTC
I am having a very similar issue which I can reproduce every time. This is almost certainly a bug in Gnome.

The crash occurs after a large number, but fixed quantity of simple (button click) touch screen events.

I am using CentOS7 kernel 3.10.0-1127.el7.x86_64 and Gnome.

bug is written here: https://bugs.centos.org/view.php?id=17301

The system crashes after using a POS system we have running on a browser. 

We swapped out google-chrome, chromium and firefox browsers. 

We finally had to give up using gnome and switched to KDE.

Comment 5 Chris Williams 2020-11-11 21:54:25 UTC
Red Hat Enterprise Linux 7 shipped it's final minor release on September 29th, 2020. 7.9 was the last minor releases scheduled for RHEL 7.
From intial triage it does not appear the remaining Bugzillas meet the inclusion criteria for Maintenance Phase 2 and will now be closed. 

From the RHEL life cycle page:
https://access.redhat.com/support/policy/updates/errata#Maintenance_Support_2_Phase
"During Maintenance Support 2 Phase for Red Hat Enterprise Linux version 7,Red Hat defined Critical and Important impact Security Advisories (RHSAs) and selected (at Red Hat discretion) Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available."

If this BZ was closed in error and meets the above criteria please re-open it flag for 7.9.z, provide suitable business and technical justifications, and follow the process for Accelerated Fixes:
https://source.redhat.com/groups/public/pnt-cxno/pnt_customer_experience_and_operations_wiki/support_delivery_accelerated_fix_release_handbook  

Feature Requests can re-opened and moved to RHEL 8 if the desired functionality is not already present in the product. 

Please reach out to the applicable Product Experience Engineer[0] if you have any questions or concerns.  

[0] https://bugzilla.redhat.com/page.cgi?id=agile_component_mapping.html&product=Red+Hat+Enterprise+Linux+7


Note You need to log in before you can comment on or make changes to this bug.