Bug 1781037 - Capacity breakdown card should show absolute values and not hourly averaged values
Summary: Capacity breakdown card should show absolute values and not hourly averaged v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Anmol Sachan
QA Contact: aberner
URL:
Whiteboard:
Depends On: 1779208
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 06:55 UTC by Anmol Sachan
Modified: 2020-01-23 11:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1779208
Environment:
Last Closed: 2020-01-23 11:18:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3709 'None' closed [release-4.3] Bug 1781037: Capacity breakdown card queries - changed average to absolute values #3709 2020-04-20 12:26:08 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:18:35 UTC

Description Anmol Sachan 2019-12-09 06:55:07 UTC
+++ This bug was initially created as a clone of Bug #1779208 +++

Description of problem:

Currently, the storage usage in the Capacity breakdown card shown is the hourly average of the values. It should be an absolute value.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create an OCS setup.
2. Push data into the setup.
3. After pushing the data, compare the actual size of data-pushed and the shown( by project, storageclass or pods)

Actual results: The usage values shown are lesser than the actual consumption.


Expected results: The usage values should be the same as consumption.


Additional info:

--- Additional comment from Anmol Sachan on 2019-12-03 14:05:07 UTC ---

Comment 2 aberner 2019-12-23 16:21:22 UTC
verified on ocp version: 4.3.0-0.nightly-2019-12-23-071857 and ocs version: 4.2 rc3

created a pod with pvc and pushed data into the pvc, Capacity breakdown card shows absolute values.

Comment 4 errata-xmlrpc 2020-01-23 11:18:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.