Bug 1781105 - The dev catalog does not filter out secondary CRDs
Summary: The dev catalog does not filter out secondary CRDs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1781101
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 10:45 UTC by Abhinandan Das
Modified: 2020-01-23 11:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1781101
Environment:
Last Closed: 2020-01-23 11:18:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:18:41 UTC

Description Abhinandan Das 2019-12-09 10:45:18 UTC
+++ This bug was initially created as a clone of Bug #1781101 +++

Description of problem:
Internal CRDs must be hidden

Version-Release number of selected component (if applicable):

4.3

How reproducible:


Steps to Reproduce:
1.Go to Dev Console-> Add+ -> From Catalog 
2. In the Dev Catalog filter by operator name
3. Internal Operators(CRD) are visible

Actual results:
Internal Operators(CRD) are visible

Expected results:

Internal Operators(CRD) should be hidden
Additional info:

Comment 1 cvogt 2019-12-09 17:52:49 UTC
PR: https://github.com/openshift/console/pull/3729

(Attempting to add a link is throwing an error 500)

Comment 3 Ruchir Garg 2020-01-07 09:57:10 UTC
Assigning defect to Gajanan More for verification.

Comment 4 Gajanan More 2020-01-07 11:46:29 UTC
This is the duplicate of ODC-2263 and which was verified by me on 4.3.0-0.nightly-2019-12-11-032710 build and I used Chrome browser with Version 78.0.3904.108.

Comment 6 errata-xmlrpc 2020-01-23 11:18:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.