Bug 1781128 - foreman-maintain failed to resume the paused task.
Summary: foreman-maintain failed to resume the paused task.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.7.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: 6.7.0
Assignee: Kavita
QA Contact: Jameer Pathan
URL:
Whiteboard:
Depends On: 1792836
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 11:49 UTC by Devendra Singh
Modified: 2020-04-14 12:58 UTC (History)
6 users (show)

Fixed In Version: rubygem-foreman_maintain-0.5.1-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-14 12:58:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 28479 Normal Closed foreman-maintain failed to resume the paused task 2020-06-12 06:04:09 UTC
Red Hat Product Errata RHBA-2020:1442 None None None 2020-04-14 12:58:39 UTC

Description Devendra Singh 2019-12-09 11:49:52 UTC
Description of problem:
Foreman-maintain failed to resume the paused task. 

Version-Release number of selected component (if applicable):
6.7

How reproducible:
always

Steps to Reproduce:
1. Start upgrade using foreman-maintain from 6.6.0 to 6.7
2. Upgrade tasks completed successfully.
3. Running Procedures after migrating to Satellite 6.7, but it was failed while resuming the paused task.

 Warning: An error occured while loading module hammer_cli_csv.
 Total tasks found paused in error state: 1
 Total tasks resumed:                     1
 Resumed tasks:                           
  1) Task identifier: 544fbdae-ad73-4dbc-bbfe-4d69579f1101
     Task action:     Update http Capsule details
     Task errors:     The world 76a9b520-b5b7-4a94-bddb-60006e70846d is not active (terminating or terminated)

Actual results:
Failed to resume the pause task

Expected results:

Resume operation should be successfully completed.

Additional info: This issue faced in Snap4 too.

Comment 6 Jameer Pathan 2019-12-19 07:31:00 UTC
Issue seems to be that "Task action: Update http Capsule details" always 
ends up in paused state during upgrade.

Comment 7 Bryan Kearney 2019-12-30 09:03:14 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/28479 has been resolved.

Comment 16 Jameer Pathan 2020-01-28 12:36:21 UTC
Verified

Verified with:
- Satellite 6.7.0 snap 10
- foreman-installer-1.24.1.5-1.el7sat.noarch
- rubygem-foreman_maintain-0.5.1-1.el7sat.noarch

Test steps:
1. Have satellite 6.6 with repos/products.
2. Upgrade Satellite to 6.7 version using foreman-maintain.

Observation:
- Satellite upgrade completed successfully.
- Foreman-maintain check related to paused task 
worked as expected.

Comment 20 errata-xmlrpc 2020-04-14 12:58:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1442


Note You need to log in before you can comment on or make changes to this bug.