Bug 1781131 - Installing 389-ds-base breaks rpm verification of python3-argcomplete
Summary: Installing 389-ds-base breaks rpm verification of python3-argcomplete
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: 389-ds-base
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: mreynolds
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 11:54 UTC by Jan Pazdziora
Modified: 2020-09-13 22:24 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.4.2.5-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-11 02:06:19 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 3813 0 None None None 2020-09-13 22:24:57 UTC

Description Jan Pazdziora 2019-12-09 11:54:47 UTC
Description of problem:

When 389-ds-base package gets installed, it regenerates /etc/bash_completion.d/python-argcomplete.sh which breaks the rpm verification due to changed timestamp.

Version-Release number of selected component (if applicable):

389-ds-base-1.4.2.5-2.fc32

How reproducible:

Deterministic.

Steps to Reproduce:
1. dnf install -y python3-argcomplete
2. rpm -V python3-argcomplete ; echo $?
   Observe the output is 0.
3. dnf install -y 389-ds-base
4. rpm -V python3-argcomplete ; echo $?

Actual results:

.......T.    /etc/bash_completion.d/python-argcomplete.sh
1

Expected results:

0

Additional info:

The 389-ds-base package should not mess with files owned by other packages.

Comment 1 Jan Pazdziora 2019-12-09 11:56:49 UTC
The 389-ds-base package now seems to invoke activate-global-python-argcomplete in its postinstall script, introduced by https://src.fedoraproject.org/rpms/389-ds-base/c/903ed99222d45c60ace9c5db07979179ef205227?branch=master.

It should not do that.

Comment 2 Fedora Update System 2019-12-09 21:04:51 UTC
FEDORA-2019-4a8d6f1db5 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4a8d6f1db5

Comment 3 Fedora Update System 2019-12-10 18:47:26 UTC
389-ds-base-1.4.2.5-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4a8d6f1db5

Comment 4 Fedora Update System 2019-12-11 02:06:19 UTC
389-ds-base-1.4.2.5-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.