Bug 1781160 - AWS: csr failed to approve if node has multiple ip addresses
Summary: AWS: csr failed to approve if node has multiple ip addresses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.2.z
Hardware: x86_64
OS: Linux
medium
urgent
Target Milestone: ---
: 4.2.z
Assignee: Brad Ison
QA Contact: Jianwei Hou
URL:
Whiteboard:
: 1779551 (view as bug list)
Depends On: 1780590
Blocks: 1779551
TreeView+ depends on / blocked
 
Reported: 2019-12-09 12:43 UTC by Brad Ison
Modified: 2020-02-25 08:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1780590
Environment:
Last Closed: 2020-01-07 17:55:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-api-provider-aws pull 279 None closed [release-4.2] Bug 1781160: Update Machine status with all instance IP addresses 2020-03-17 09:25:31 UTC
Github openshift cluster-machine-approver pull 59 None closed [release-4.2] Bug 1781160: Fall back to machine-api check if certificate check fails 2020-03-17 09:25:34 UTC
Red Hat Product Errata RHBA-2020:0014 None None None 2020-01-07 17:55:25 UTC

Comment 1 Brad Ison 2019-12-18 11:16:58 UTC
*** Bug 1779551 has been marked as a duplicate of this bug. ***

Comment 3 Jianwei Hou 2019-12-20 04:39:05 UTC
Verified in 4.2.0-0.nightly-2019-12-20-002556

urrent SAN Values: [ip-10-0-158-112.us-east-2.compute.internal 10.0.158.112], CSR SAN Values: [ip-10-0-158-112.us-east-2.compute.internal 10.0.149.85 10.0.158.112]
I1220 04:35:46.325261       1 csr_check.go:180] Falling back to machine-api authorization for ip-10-0-158-112.us-east-2.compute.internal

Comment 5 errata-xmlrpc 2020-01-07 17:55:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0014


Note You need to log in before you can comment on or make changes to this bug.