Bug 1781246 - 404 not found when selecting edit action for cluster-scoped operands
Summary: 404 not found when selecting edit action for cluster-scoped operands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1782558
TreeView+ depends on / blocked
 
Reported: 2019-12-09 15:59 UTC by Irina Gulina
Modified: 2020-05-13 21:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the OpenShift console Installed Operators page would not allow you to edit a cluster-scoped operand. Instead, you would see a 404 error. Console now correctly takes you to the YAML editor for the operand.
Clone Of:
: 1782558 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:54:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
#1 screenshot, edit in drop down (86.49 KB, image/png)
2019-12-09 16:00 UTC, Irina Gulina
no flags Details
#2 screenshot, jump to YAML tab, 404 Not Found, Undefined project (29.07 KB, image/png)
2019-12-09 16:01 UTC, Irina Gulina
no flags Details
#3 screenshot, Overview tab also 404 Not Found and Undefined project (27.30 KB, image/png)
2019-12-09 16:02 UTC, Irina Gulina
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3732 None closed Bug 1781246: Fix edit link for cluster-scoped operand 2020-04-24 14:23:44 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:54:22 UTC

Description Irina Gulina 2019-12-09 15:59:19 UTC
Description of problem:
404 Not Found is shown when one wants to Edit any instance of the operator in a namespace where the operator has been copied to.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-04-054458   True        False         3h54m   


How reproducible:
always


Steps to Reproduce:
1. install operator, for example CNV in openshift-cnv ns, all other ns will show it as "Copied"
2. open that installed operator, CNV in any ns where it has been "Copied" to, not "InstallSucceeded". 
3. navigate to "All Instances" tab or a tab of a particular instance. 
4. Pick any operand from the list, hit three dots menu, there "Edit <instance>".
Observe 404 Not Found and that Project switched to UNDEFINED. Any other tab Overview and Resources also will show 404 Not Found. Notice that "Delete <instance>" in that tree dots menu works fine.

Actual results:
screenshots attached

Comment 1 Irina Gulina 2019-12-09 16:00:23 UTC
Created attachment 1643333 [details]
#1 screenshot, edit in drop down

Comment 2 Irina Gulina 2019-12-09 16:01:41 UTC
Created attachment 1643343 [details]
#2 screenshot, jump to YAML tab, 404 Not Found, Undefined project

Comment 3 Irina Gulina 2019-12-09 16:02:47 UTC
Created attachment 1643344 [details]
#3 screenshot, Overview tab also 404 Not Found and Undefined project

Comment 5 Samuel Padgett 2019-12-09 17:54:16 UTC
Looks like this is happening because it's a cluster-scoped resource.

Comment 7 Samuel Padgett 2019-12-09 18:08:16 UTC
Fixed by https://github.com/openshift/console/pull/3732

Comment 9 XiaochuanWang 2019-12-17 07:12:40 UTC
Followed description steps, the "Edit <instance>" works fine.
Verified on 4.4.0-0.nightly-2019-12-16-124946

Comment 11 errata-xmlrpc 2020-05-13 21:54:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.