Bug 1781288 - WARNING: CPU: 2 PID: 1 at kernel/trace/trace.c:8106 create_trace_option_files+0x1ef/0x220
Summary: WARNING: CPU: 2 PID: 1 at kernel/trace/trace.c:8106 create_trace_option_files...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-09 17:20 UTC by Chris Murphy
Modified: 2020-03-03 19:47 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-03 19:47:33 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Linux Kernel 205921 None None None 2019-12-19 21:49:41 UTC

Description Chris Murphy 2019-12-09 17:20:23 UTC
This splat is a regression from 5.3.x series, and results in tainted kernel on every startup. Still happens with 5.4.2.


Dec 06 23:26:27 flap.local kernel: WARNING: CPU: 2 PID: 1 at kernel/trace/trace.c:8106 create_trace_option_files+0x1ef/0x220
Dec 06 23:26:27 flap.local kernel: Modules linked in:
Dec 06 23:26:27 flap.local kernel: CPU: 2 PID: 1 Comm: swapper/0 Tainted: G        W         5.4.2-300.fc31.x86_64 #1
Dec 06 23:26:27 flap.local kernel: Hardware name: HP HP Spectre Notebook/81A0, BIOS F.43 04/16/2019
Dec 06 23:26:27 flap.local kernel: RIP: 0010:create_trace_option_files+0x1ef/0x220


Upstream is looking into it.
https://lkml.org/lkml/2019/11/1/678

Comment 1 Chris Murphy 2019-12-10 00:35:25 UTC
I'm not seeing it with 5.5.0-0.rc1.git0.1.fc32.x86_64+debug

Comment 2 Chris Murphy 2019-12-19 21:50:18 UTC
This is still happening in 5.4.5-300.fc31.x86_64

Comment 3 Chris Murphy 2019-12-19 22:30:52 UTC
Should be fixed by commit: a356646a56857c2e5ad875beec734d7145ecd49a ("tracing: Do not create directories if lockdown is in affect")

I'm not seeing it in linux-stable@ though

Comment 4 Justin M. Forbes 2020-03-03 16:19:07 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 31 kernel bugs.

Fedora 31 has now been rebased to 5.5.7-200.fc31.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 32, and are still experiencing this issue, please change the version to Fedora 32.

If you experience different issues, please open a new bug report for those.

Comment 5 Chris Murphy 2020-03-03 19:47:33 UTC
I'm not seeing it in 5.5 or 5.6. Closing.


Note You need to log in before you can comment on or make changes to this bug.