Bug 17814 - -i flag in cp overrides -f
Summary: -i flag in cp overrides -f
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-24 19:13 UTC by Frank Sweetser
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-24 19:13:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Sweetser 2000-09-24 19:13:55 UTC
Previously, -f used to override the -i flag.  In cp, this is no longer the
case, while it appears to be so in rm.

> touch foo
> touch bar
> /bin/cp -i -f foo bar
/bin/cp: overwrite 'bar`? y
>/bin/rm -i -f bar
>

Comment 1 Bernhard Rosenkraenzer 2000-10-01 22:24:07 UTC
It's not a bug, it's a feature.
I don't like it either, but POSIX demands it.

Comment 2 Bernhard Rosenkraenzer 2000-12-18 15:52:01 UTC
*** Bug 22451 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.