Bug 1781454 - [rhel-8.2][RDMA] package dependency issue after merge infiniband-diags into rdma-core
Summary: [rhel-8.2][RDMA] package dependency issue after merge infiniband-diags into r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rdma-core
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 8.2
Assignee: Honggang LI
QA Contact: Afom T. Michael
URL:
Whiteboard:
Depends On:
Blocks: 1723598 1783446
TreeView+ depends on / blocked
 
Reported: 2019-12-10 03:48 UTC by Honggang LI
Modified: 2020-04-28 16:57 UTC (History)
4 users (show)

Fixed In Version: rdma-core-26.0-5.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:57:33 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1865 None None None 2020-04-28 16:57:51 UTC

Description Honggang LI 2019-12-10 03:48:09 UTC
Description of problem:

https://rpmdiff.engineering.redhat.com/run/425111/20/

NEEDS INSPECTION 	rdma-core-devel 	

Subpackage rdma-core-devel on i686 consumes libraries libibmad.so.5 libibnetdisc.so.5 from subpackage infiniband-diags but does not have explicit package version requirement.
Please add Requires: infiniband-diags = %{version}-%{release} to rdma-core-devel in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.


NEEDS INSPECTION 	infiniband-diags 	

Subpackage infiniband-diags on i686 consumes libraries libibumad.so.3 libibumad.so.3(IBUMAD_1.0) libibumad.so.3(IBUMAD_1.1) from subpackage libibumad but does not have explicit package version requirement.
Please add Requires: libibumad = %{version}-%{release} to infiniband-diags in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.


NEEDS INSPECTION 	rdma-core-devel 	

Subpackage rdma-core-devel on aarch64 x86_64 ppc64le s390x consumes libraries libibmad.so.5()(64bit) libibnetdisc.so.5()(64bit) from subpackage infiniband-diags but does not have explicit package version requirement.
Please add Requires: infiniband-diags = %{version}-%{release} to rdma-core-devel in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.


NEEDS INSPECTION 	infiniband-diags 	

Subpackage infiniband-diags on aarch64 x86_64 ppc64le s390x consumes libraries libibumad.so.3()(64bit) libibumad.so.3(IBUMAD_1.0)(64bit) libibumad.so.3(IBUMAD_1.1)(64bit) from subpackage libibumad but does not have explicit package version requirement.
Please add Requires: libibumad = %{version}-%{release} to infiniband-diags in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Honggang LI 2019-12-11 12:52:16 UTC
*** Bug 1782173 has been marked as a duplicate of this bug. ***

Comment 2 Nathan Scott 2019-12-11 20:01:10 UTC
Hi Hongang,

Can you provide a timeframe for this to be fixed please?  This is blocking an urgent PCP update for RHEL 8.2.  Alternatively, is there a workaround I can use within the pcp spec file temporarily, perhaps adding a build dep on infiniband-diags or something like that?

Many thanks!

Comment 3 Honggang LI 2019-12-12 00:39:17 UTC
(In reply to Nathan Scott from comment #2)
> Hi Hongang,
> 
> Can you provide a timeframe for this to be fixed please? 

I had a scratch build of rdma-core in last night. It should be fixed in today.

Comment 5 Honggang LI 2019-12-12 02:12:35 UTC
(In reply to Honggang LI from comment #3)
> (In reply to Nathan Scott from comment #2)
> > Hi Hongang,
> > 
> > Can you provide a timeframe for this to be fixed please? 
> 
> I had a scratch build of rdma-core in last night. It should be fixed in
> today.

Issue should be fixed with rdma-core-26.0-5.el8. If you have any problem with rdma-core, please let me know.

Comment 6 Nathan Scott 2019-12-13 03:48:21 UTC
(In reply to Honggang LI from comment #5)
> [...]
> Issue should be fixed with rdma-core-26.0-5.el8. If you have any problem
> with rdma-core, please let me know.

Thanks Honggang.  Only issue so far is it doesn't appear to be available in the build root yet, so the pcp build still fails - I guess that will change soon though now.

Thanks for the quick response!

Comment 7 Afom T. Michael 2020-01-28 23:02:48 UTC
rdma-core.spec of rdma-core-26.0-5 vs older shows for infiniband-diags, "Requires: libibumad = %{version}-%{release}" is added.

In rdma-core.spec of rdma-core-26.0-5.el8.src.rpm has the following:
    %package -n infiniband-diags
    Summary: InfiniBand Diagnostic Tools
    Requires: libibumad = %{version}-%{release}


diff between rdma-core.spec of rdma-core-26.0-4.el8.src.rpm & rdma-core-26.0-5.el8.src.rpm has:
    %package -n infiniband-diags
     Summary: InfiniBand Diagnostic Tools
    +Requires: libibumad = %{version}-%{release}

Comment 8 Afom T. Michael 2020-02-04 21:58:38 UTC
Moving to verified. rdma-core-26.0-5.el8.src.rpm and later spec file, rdma-core-devel section has these required dependencies as shown below.

$ grep -A 34 "^%package devel" ./rdma-core-26.0.5/rdma-core.spec | grep -E "^Requires: infiniband-diags|^Requires: libibumad"
Requires: libibumad = %{version}-%{release}
Requires: infiniband-diags = %{version}-%{release} 
$
$ rpm --query --requires ./rdma-core-devel-26.0-7.el8.x86_64.rpm | grep -E "libibumad = |infiniband-diags = "
infiniband-diags = 26.0-7.el8
libibumad = 26.0-7.el8
$ rpm --query --requires ./rdma-core-devel-26.0-7.el8.aarch64.rpm | grep -E "libibumad = |infiniband-diags = "
infiniband-diags = 26.0-7.el8
libibumad = 26.0-7.el8
$ rpm --query --requires ./rdma-core-devel-26.0-7.el8.i686.rpm | grep -E "libibumad = |infiniband-diags = "
infiniband-diags = 26.0-7.el8
libibumad = 26.0-7.el8
$ rpm --query --requires ./rdma-core-devel-26.0-7.el8.ppc64le.rpm | grep -E "libibumad = |infiniband-diags = "
infiniband-diags = 26.0-7.el8
libibumad = 26.0-7.el8
$ rpm --query --requires ./rdma-core-devel-26.0-7.el8.s390x.rpm | grep -E "libibumad = |infiniband-diags = "
infiniband-diags = 26.0-7.el8
libibumad = 26.0-7.el8
$

Comment 10 errata-xmlrpc 2020-04-28 16:57:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1865


Note You need to log in before you can comment on or make changes to this bug.