Bug 178148 - "add this launcher to panel" for launcher with no icon crashes panel on properties
Summary: "add this launcher to panel" for launcher with no icon crashes panel on prope...
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-18 01:42 UTC by Ricky Ng-Adam
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 15:53:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ricky Ng-Adam 2006-01-18 01:42:18 UTC
Description of problem:

Doing "add this launcher to panel" for launcher with no icon (such as Add/Remove
software) crashes panel when right-clicking and doing "Properties"

Version-Release number of selected component (if applicable):

(is it normal I have two of those?) 

[rngadam@localhost ~]$ rpm -q gnome-panel 
gnome-panel-2.13.4-1
gnome-panel-2.13.5-1


How reproducible:

always

Steps to Reproduce:
1. add launcher to panel
2. try to view properties
3.
  
Actual results:

crash

Expected results:

properties even if no icon

Additional info:

Comment 1 Eric Wood 2006-01-20 20:55:18 UTC
# yum update gnome-panel worked for me.  I only have 2.13.5-1 installed.

Without filing another bug report, this may be much related:

1. Dragging the web browser launcher (icon) to the desktop creates a
"redhat-web.desktop" file.  
2. Dragging the web browser launcher off and back onto itself (because I wanted
to cancel my dragging action), cause the icon to vanish.  Same with email.

Overall, dragging and dropping of lauchers/icons between various panels and the
desktop needs some polishing. 

Comment 2 Rahul Sundaram 2006-02-20 10:58:28 UTC

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks

Comment 3 Red Hat Bugzilla 2007-02-05 19:13:27 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 4 Matthew Miller 2007-04-06 17:12:41 UTC
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]


Comment 5 Ricky Ng-Adam 2007-04-28 18:27:11 UTC
I'm unable to reproduce this in FC7 test 4 because the panel just rejects any
attempts to add a launcher to the panel without an icon.  I would have thought
that providing a default icon image at all time would have been a better
solution, but at least the panel doesn't crash anymore.

Comment 6 Ray Strode [halfline] 2007-08-14 15:53:08 UTC
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)


Note You need to log in before you can comment on or make changes to this bug.