Bug 178153 - epiphany incorrectly compiled against libXt-devel
epiphany incorrectly compiled against libXt-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-17 21:49 EST by Michel Alexandre Salim
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 06:37:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2006-01-17 21:49:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
On a cleanly installed system without X development libraries, Epiphany crashes on startup with the following:

LoadPlugin: failed to initialize shared library libXt.so [libXt.so: cannot open shared object file: No such file or directory]
LoadPlugin: failed to initialize shared library libXext.so [libXext.so: cannot open shared object file: No such file or directory]

Symlinking libXt.so.6 to libXt.so does not solve the problem; one had to install libXt-devel before Epiphany would start (the missing libXext.so does not seem to matter). Just installing libXt-devel with --nodeps allows Epiphany to run.

It looks like the package was built against the static libraries?


Version-Release number of selected component (if applicable):
epiphany-1.9.4-1

How reproducible:
Always

Steps to Reproduce:
1. yum install epiphany
2. yum remove libXt-devel libXext-devel
3. epiphany
  

Actual Results:  Epiphany should run; it does not depend on libXt-devel and libXext-devel

Expected Results:  Epiphany does not run, terminating with the LoadPlugin errors. On the second attempt it would display the dialog box asking if the previous windows should be recovered, then terminate with the same LoadPlugin errors.



Additional info:
Comment 1 Michel Alexandre Salim 2006-01-21 11:19:53 EST
Bug still present in epiphany-1.9.5.1-1
Comment 2 Christopher Aillon 2006-01-21 12:08:49 EST
Think this is a bug in the libXt package.  mharris what do you think?
Comment 3 Mike A. Harris 2006-01-23 11:07:50 EST
Bug in Epiphany.  It should not be dlopen'ing libXt.so as that is a devel
symlink, as in every other library package in the OS.  It should either
be dlopen()ing the versioned .so, or dynamically linking properly to libXt,
like other apps do.

Definitely not an Xt bug.

HTH
Comment 4 Matthias Clasen 2006-01-31 15:30:11 EST
Mike, I am pretty sure epiphany is not dlopening libXt.so, as that string does
not occur in the sources at all. Any change this could be related to another
problem (bug 179044) where we see unversioned X libs being openend ?
Comment 5 Christopher Aillon 2006-02-16 13:38:53 EST
I actually can't reproduce this at all.  Epiphany starts fine for me, and so
does mozilla.  What plugins do you have installed if any?
Comment 6 Michel Alexandre Salim 2006-02-18 23:13:02 EST
I can't reproduce this anymore either (1.9.7). As for plugins, I had the 32-bit
Flash and Java plugins installed (only the Flash plugin is in the global plugins
directory, though, and I did not get a "wrong ELF class" error so Epiphany was
not trying to load it)

Should I close the bug?
Comment 7 Rahul Sundaram 2006-02-20 06:37:04 EST

Closing this report as per the last comments. Kindly reopen if you can reproduce
this consistently. 

Note You need to log in before you can comment on or make changes to this bug.