Bug 1781769 - Dnf does not correctly detect the latest version of the module stream
Summary: Dnf does not correctly detect the latest version of the module stream
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Jaroslav Mracek
QA Contact: Jan Blazek
URL:
Whiteboard:
: 1779899 (view as bug list)
Depends On:
Blocks: 1186913 1734579 1779899
TreeView+ depends on / blocked
 
Reported: 2019-12-10 14:32 UTC by Marek Blaha
Modified: 2020-04-28 16:49 UTC (History)
5 users (show)

Fixed In Version: dnf-4.2.17-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:49:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:22 UTC

Description Marek Blaha 2019-12-10 14:32:35 UTC
Description of problem:

The _get_latest() function of the module_base.py compares module versions as strings, but they are actually numbers. So at the moment the version 
820190206164045 is considered higher then 8010020190902091509.

Comment 1 Jaroslav Mracek 2019-12-11 11:21:41 UTC
I create a patch that fix detection of latest module (https://github.com/rpm-software-management/dnf/pull/1548)
Tests: https://github.com/rpm-software-management/ci-dnf-stack/pull/728

Comment 4 David Darrah/Red Hat QE 2019-12-16 20:05:13 UTC
*** Bug 1779899 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2020-04-28 16:49:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.