Bug 1781856 - Failed to connect to 802.1X
Summary: Failed to connect to 802.1X
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 8.2
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1739559
TreeView+ depends on / blocked
 
Reported: 2019-12-10 17:58 UTC by Jiri Koten
Modified: 2020-04-28 16:54 UTC (History)
7 users (show)

Fixed In Version: NetworkManager-1.22.8-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:53:59 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
nmcli debug log (340.49 KB, text/plain)
2019-12-10 17:58 UTC, Jiri Koten
no flags Details
old nmcli debug trace (189.40 KB, text/plain)
2019-12-12 09:54 UTC, Jiri Koten
no flags Details
ifcfg (517 bytes, text/plain)
2019-12-12 16:15 UTC, Jiri Koten
no flags Details
nmcli debug log (247.96 KB, text/plain)
2019-12-12 16:43 UTC, Jiri Koten
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:24 UTC

Description Jiri Koten 2019-12-10 17:58:08 UTC
Created attachment 1643703 [details]
nmcli debug log

Description of problem:
I'm no longer to connect to our internal WPA2 Red Hat Wifi.
Downgrading to 1.22.0-0.1.el8 works fine.

Version-Release number of selected component (if applicable):
NetworkManager-1.22.0-0.2.el8

How reproducible:
100%

Steps to Reproduce:
1.connect to Red Hat Wifi
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Thomas Haller 2019-12-11 07:29:36 UTC
hm, are you sure that 1.22.0-0.1.el8 works? That would be unexpected, but if you are sure, quite some important information.

Without this piece of information I would have said this is a wpa-supplicant or driver issue...

Could you also attach a level=TRACE log with a working case? Thank you.

Comment 2 Jiri Koten 2019-12-12 09:54:08 UTC
Created attachment 1644352 [details]
old nmcli debug trace

Successfully connected with  NetworkManager-1.22.0-0.1.el8

Comment 3 Beniamino Galvani 2019-12-12 14:34:04 UTC
It seems the new internal DHCP client implementation times out when requesting a lease:

[1575993447.6522] dhcp4 (wlp2s0): sent DISCOVER to 0.0.0.0
...
[1575993485.4081] dhcp4 (wlp2s0): request timed out

The old client based on systemd is working well instead.

Comment 4 Jiri Koten 2019-12-12 15:12:15 UTC
I can confirm this, if I use dhclient option with NetworkManager-1.22.0-0.2.el8, I'm able to connect.

$ NetworkManager --print-config
# NetworkManager configuration: /etc/NetworkManager/NetworkManager.conf (etc: 99-dhcp.conf)          

[main]
# plugins=ifcfg-rh
# rc-manager=symlink
# auth-polkit=true
dhcp=dhclient

[logging]
# backend=journal
# audit=false

# no-auto-default file "/var/lib/NetworkManager/no-auto-default.state"

Comment 5 Thomas Haller 2019-12-12 15:45:00 UTC
Also, the Wi-Fi settings for wpa-supplicant differ. Which is odd...

Jiri, cuould you please also show the profile in question?
First, identify the file in which it is stored:

  nmcli -f UUID,NAME,FILENAME connection show


Then, attach the corresponding file (sanitizing private data first!!).

Probably it's in "/etc/sysconfig/network-scripts/ifcfg-$NAME". In that case, make sure to include all relevant "/etc/sysconfig/network-scripts/*-$NAME" files.

Comment 6 Jiri Koten 2019-12-12 16:15:43 UTC
Created attachment 1644480 [details]
ifcfg

The AUTH_RETRIES=1 were suggested by Vladimir, but it didn't make it work.

Comment 7 Jiri Koten 2019-12-12 16:43:36 UTC
Created attachment 1644489 [details]
nmcli debug log

(In reply to Thomas Haller from comment #5)
> Also, the Wi-Fi settings for wpa-supplicant differ. Which is odd...

As part of debugging, I have deleted the old profile and created new one from scratch. 

This output is from the profile I have pasted and the same I used with the -1 build.

Comment 9 Beniamino Galvani 2019-12-13 13:35:05 UTC
Hi Jiri,

could you please capture packet traces when NM tries to connect, first with dhcp=internal and then with dhcp=dhclient? You can use a command like:

sudo tcpdump -i any -w wifi-internal.pcap

You can send the output files via email to me if you prefer. Thank you.

Comment 18 Beniamino Galvani 2019-12-20 10:56:32 UTC
Related:

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/issues/310

Comment 19 Beniamino Galvani 2019-12-20 13:45:24 UTC
Upstream merge request:

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/368

Comment 23 Jiri Koten 2020-04-08 07:01:24 UTC
I cannot reproduce anymore, with or without lease file.

Comment 25 errata-xmlrpc 2020-04-28 16:53:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.