Bug 1782163 - Builds faling due to missing packages (e.g. python3-kuryr-lib)
Summary: Builds faling due to missing packages (e.g. python3-kuryr-lib)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
: 4.4.0
Assignee: Michał Dulko
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On:
Blocks: 1782164
TreeView+ depends on / blocked
 
Reported: 2019-12-11 10:14 UTC by Michał Dulko
Modified: 2020-05-13 21:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1782164 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:54:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:54:42 UTC

Description Michał Dulko 2019-12-11 10:14:43 UTC
Description of problem:
Kuryr-Kubernetes uses OSP16 repositories to install its dependencies (mostly Python RPM's). As Kuryr is not part of OSP anymore, some of it dependencies (those not required by any other project) got removed from OSP16 and this causes Kuryr builds in OCP to fail.

The correct approach here is to cross-tag those packages into OCP, because that solves some more issues:
* OKD builds cannot have OSP16 packages.
* OSP16 is not released before 4.3.

That work is handled in Shared Content Request [1] and RCM ticket [2].

[1] https://mojo.redhat.com/docs/DOC-1212437
[2] https://projects.engineering.redhat.com/browse/RCM-72513

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just check build results (upstream or downstream)
2.
3.

Actual results:
Builds fail with:
- nothing provides python3-grpcio >= 1.12.0 needed by python3-kuryr-kubernetes-4.4.1-1.el7.noarch
  - nothing provides python3-kuryr-lib >= 0.5.0 needed by python3-kuryr-kubernetes-4.4.1-1.el7.noarch
  - nothing provides python3-protobuf >= 3.6.0 needed by python3-kuryr-kubernetes-4.4.1-1.el7.noarch

Expected results:
Builds complete normally.


Additional info:

Comment 1 Michał Dulko 2019-12-20 17:37:15 UTC
With https://github.com/openshift/ocp-build-data/pull/254 merged and a few more packages tagged into 4.4 this should be ready to test.

Comment 2 Jon Uriarte 2019-12-24 09:39:18 UTC
Verified in 4.4.0-0.nightly-2019-12-20-210709 on 2019-12-13.1 OSP 13 puddle.

The OCP installer finishes successfully:

 $ oc get clusterversion
 NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
 version   4.4.0-0.nightly-2019-12-20-210709   True        False         14h     Cluster version is 4.4.0-0.nightly-2019-12-20-210709

Kuryr cni and controller version:
 · kuryr-cni image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:0a9f8f611d98455e0f494615fc510399760c1388f2b7915c444f380e44832541
 · kuryr-controller image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:efa13ad0d7e5096510036ba625879ca465ed20491f87a1d68b36d94abfabe363

Comment 4 errata-xmlrpc 2020-05-13 21:54:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.