Bug 1782185 - Accessing Storage > Volumes does not work
Summary: Accessing Storage > Volumes does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.3.6.7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ovirt-4.3.9
: 4.3.9.1
Assignee: shani
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-11 11:19 UTC by Valentin Bajrami
Modified: 2020-03-20 07:57 UTC (History)
4 users (show)

Fixed In Version: ovirt-engine-4.3.9.1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-20 07:57:15 UTC
oVirt Team: Storage
Embargoed:
pm-rhel: ovirt-4.3+
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)
ui.log (13.16 KB, text/plain)
2019-12-11 11:19 UTC, Valentin Bajrami
no flags Details
engine.log (261.37 KB, text/plain)
2019-12-11 11:20 UTC, Valentin Bajrami
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github oVirt/ovirt-engine/blob/master/frontend/webadmin/modules/uicompat/src/main/resources/org/ovirt/engine/ui/uicompat/LocalizedEnums.properties#L723 0 None None None 2020-08-27 12:57:50 UTC
oVirt gerrit 106285 0 master MERGED webadmin: Add StorageFormatType___V5 to LocalizedEnums 2021-02-11 13:53:15 UTC
oVirt gerrit 106304 0 ovirt-engine-4.3 MERGED webadmin: Fix NPE that may raise in SubTabHostVmView 2021-02-11 13:53:15 UTC
oVirt gerrit 106305 0 ovirt-engine-4.3 MERGED webadmin: Add StorageFormatType___V5 to LocalizedEnums 2021-02-11 13:53:15 UTC

Description Valentin Bajrami 2019-12-11 11:19:21 UTC
Created attachment 1643845 [details]
ui.log

Recently, I upgraded ovirt-engine from 4.2.5.3-1.el7 to 4.3.6.7-1.el7 
but going to  Storage > Volumes   nothing seems to happen. Volumes does
not open up.

The error I see in the debugger mode (firefox) is as follows:

org.ovirt.engine.ui.uicompat.EnumTranslator WARNING: Missing Enum
resource 'V5'. Cannot find constant 'StorageFormatType___V5'; expecting
a method name.  There is also a bug here:
https://bugzilla.redhat.com/show_bug.cgi?id=1759102  and here: https://bugzilla.redhat.com/show_bug.cgi?id=1574605

Any fix / workaround?

Comment 1 Valentin Bajrami 2019-12-11 11:20:05 UTC
Created attachment 1643846 [details]
engine.log

Comment 2 RHEL Program Management 2019-12-18 14:27:49 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 3 shani 2020-01-13 11:54:09 UTC
Hi Valentin,
I've tried to reproduce it on 4.3.8 but it works for me.

Also, The bugs you've mentioned are already closed.

In case you still encounter this issue, 
Can you please attach a screenshot and also specify your current version?

Comment 4 shani 2020-01-14 12:38:58 UTC
Hi Valentin,
I had another look at your ui.log and your bug's description.

The error you've mentioned, (Cannot find constant 'StorageFormatType___V5') didn't appear on the UI log,
and it seems, from the UI log, that you got an NPE from another resource (SubTabHostVmView.java:119).

For the first error, I've uploaded a patch that adds the missing constant and backported it.
For the second error, I've backported an exists patch from the master's version.

Both should be available for 4.3.

Comment 5 Valentin Bajrami 2020-01-14 13:14:54 UTC
Hi Shani,

Thank you for having a look into it and patching it! I am going to test this the coming days and report back here!

Comment 10 SATHEESARAN 2020-03-02 13:11:47 UTC
Tested with upgrade from RHV 4.2.8 to RHV 4.3.9, with hyperconverged RHV and RHGS 3.5.1 setup.
This issue is not seen. No errors or NPE observed.

Comment 11 Sandro Bonazzola 2020-03-20 07:57:15 UTC
This bugzilla is included in oVirt 4.3.9 release, published on March 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.3.9 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.