Bug 178222 - Installer drops pci=noacpi option from /etc/grub.conf
Installer drops pci=noacpi option from /etc/grub.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: booty (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 12:24 EST by Richard Lloyd
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.71-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 16:15:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Lloyd 2006-01-18 12:24:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051202 Fedora/1.5-0.fc4 Firefox/1.5

Description of problem:
Anaconda's seems to drop "pci=noapic" when writing out the grub configuration to /etc/grub.conf towards the end of the installation process of Fedora Core 5 Test 2 (x86_64 on DVD).


Version-Release number of selected component (if applicable):
anaconda-10.91.4-1

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora Core 5 Test 2 x86-64 DVD ISO (I'm using an Acer Aspire T140)
2. Type "linux pci=noapi noapic" and press Enter
3. Go through the entire install process and reboot
4. Examine contents of kernel line in /etc/grub.conf (e.g. "e" option in grub boot loader)
  

Actual Results:  The kernel line in /etc/grub.conf after installation only has "noapic" as an additional option.

Expected Results:  The kernel line should have had both the additional options included, i.e. "pci=noacpi noapic" (no double quotes in the line itself of course).

Additional info:

If I don't specify both of these options, my Acer Aspire T140 Athlon 64 3200+ desktop PC (NForce 4 Nvidia motherboard with SATA hard drives) will fail to detect hard drives early on in anaconda and it aborts. Also, if the same options aren't both present in the appropriate kernel line in /etc/grub.conf when the machine boots, I get a kernel panic and halt.

Note that Fedora Core 5 Test 1 had this problem too, but Fedora Core 4 (final) doesn't. I thought that it would be sorted out by Test 2, but the problem is still there.
Comment 1 Richard Lloyd 2006-01-18 12:27:06 EST
Oops, that should be "pci=noacpi" in a couple places early in that report (I
can't spell :-( ).
Comment 2 Jeremy Katz 2006-01-18 12:30:11 EST
We only keep some of the options going from anaconda to the installed system as
some of the options you can pass are specific to anaconda (or other things).

pci= should probably be added to the list, though.
Comment 3 Rahul Sundaram 2006-02-20 06:13:55 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Richard Lloyd 2006-02-22 06:22:21 EST
Just a note that I can confirm that FC5 Test 3 still has this problem -
pci=noacpi is still missing from /etc/grub.conf after installation. I've
adjusted the Version field to reflect this, but I'm wondering if its severity
should be "regression", since it's worked OK before in all final releases of
Fedora Core?

It's something I'd like to see fixed before next month's FC5 final release
(otherwise this problem will persist forever for FC5 and won't get a fix until
FC6T1), but I guess if people are savvy enough to type "linux pci=noapic noapic"
at the start of the installer (a shame we can't auto-detect when such options
are needed), then they'll be clued up enough to edit /etc/grub.conf to put the
missing option back in.
Comment 5 Peter Jones 2006-03-14 16:15:53 EST
Thanks, fixed in next release.

Note You need to log in before you can comment on or make changes to this bug.