Bug 178228 - gnome-panel crashes on attempt to logout or shutdown
gnome-panel crashes on attempt to logout or shutdown
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2006-01-18 12:54 EST by Gerry Tool
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 11:26:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gnome Panel backtrace (10.23 KB, text/plain)
2006-01-21 00:41 EST, Brian Pepple
no flags Details

  None (edit)
Description Gerry Tool 2006-01-18 12:54:09 EST
Description of problem:I have a fresh install FC5T2 completely up to date with
today's updates.
Whenever I try to logout  or shutdown via the panel System menu, I get
an error dialog that says 'The Application "gnome-panel" has quit
unexpectedly." with buttons to Restart Application or Close.  Clicking
either, causes the panel to restart, but I can never log out without
going to another terminal with Ctrl-Alt-Fx and rebooting.


Version-Release number of selected component (if applicable):
gnome-panel-2.13.5-1

How reproducible:
Always

Steps to Reproduce:
1.Use System > Log Out or System > Shut Down menu item
2.
3.
  
Actual results:an error dialog that says 'The Application "gnome-panel" has quit
unexpectedly." with buttons to Restart Application or Close.


Expected results: normal log out or shutdown


Additional info: the only way I can get out of the desktop is to use Ctrl-Alt-Fx
and login as root and reboot.  Usint Ctrl-Alt-Backspace results in a black
window with a cursor blinking in upper left and a mouse cursor active.
Comment 1 Brian Pepple 2006-01-21 00:40:56 EST
I'm experiencing the exact same problem.  Changing the severity to high since it
crashes every time, and the only way to get out of the loop is to kill X.  I'll
attach a backtrace.
Comment 2 Brian Pepple 2006-01-21 00:41:47 EST
Created attachment 123520 [details]
Gnome Panel backtrace
Comment 3 Ian Burrell 2006-01-21 18:47:28 EST
Following an email on the fedora-devel list, after deselecting "Enable software
sound mixing (ESD)" in the Preferences, Sound control panel, gnome-panel does
not crash log out and shut down happen normally.  Select the checkbox and
gnome-panel crashes.
Comment 4 Gerry Tool 2006-01-21 19:30:27 EST
I confirm that Ian Burrell's note above is correct.  I unchecked the box and I
can now logout normally.  I hope this is a good clue to the cause of the problem.
Comment 5 Christopher Aillon 2006-01-27 14:39:11 EST
Ray will look at this.
Comment 6 Gerry Tool 2006-01-31 11:26:19 EST
This is now fixed after installing rawhide updates on 1/31/06

Note You need to log in before you can comment on or make changes to this bug.