Bug 1782407 - [CNV] VM filtering works incorrect, running VM is filtered as other
Summary: [CNV] VM filtering works incorrect, running VM is filtered as other
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-11 15:01 UTC by Igor Braginsky
Modified: 2020-05-13 21:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:54:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
VM filtering works wrong (31.73 KB, image/png)
2019-12-11 15:01 UTC, Igor Braginsky
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3971 None closed Bug 1782407: Update virtual machines table filter 2020-05-22 18:31:50 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:54:45 UTC

Description Igor Braginsky 2019-12-11 15:01:20 UTC
Created attachment 1643983 [details]
VM filtering works wrong

Description of problem:
When VM UI is showing 3 VMs, one of them running - it is filtered as "Other"


Version-Release number of selected component (if applicable): CNV 2.2.0-10


How reproducible: 100%


Steps to Reproduce:
1. Migrate several VMs, 3 or more
2. Run one of them
3. Take a look on counters on filters

Actual results:
Filter "Other" will show 1 while filter "Running" will show 0

Expected results:
Filters should show relevant numbers

Additional info:

Comment 3 Guohua Ouyang 2020-02-18 08:34:22 UTC
verified on 4.4.0-0.nightly-2020-02-10-111955.

Comment 4 Yaacov Zamir 2020-04-30 08:33:41 UTC
not require doc text - docs stay the same after bug

Comment 6 errata-xmlrpc 2020-05-13 21:54:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.