Bug 178241 - failure: repodata/repomd.xml - No more mirrors to try
failure: repodata/repomd.xml - No more mirrors to try
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 14:32 EST by shrek-m
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 15:08:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fc5t2 ppc boot.iso hdinst anaconda.log (19.29 KB, text/x-log)
2006-01-28 16:32 EST, shrek-m
no flags Details

  None (edit)
Description shrek-m 2006-01-18 14:32:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.7.12-1.3.1

Description of problem:
anaconda fails while harddrive install (isos, usbdisk) on powermac g5.

"reading package metadata: failure: repodata/repomd.xml from anaconda: [Errno 256] No more mirrors to try"


FC5-test2-ppc-boot.iso
boot: linux text expert askmethod video=ofonly 

FC5-test2-ppc-disc1.iso (not bootable)
alt+apple+o+f
0 > boot cd:,\ppc\mac\ofboot.b
boot: linux text askmethod video=ofonly 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot
2. select hardrive install
3. select sdc1 (isos, usbdisk)
4. ..., partition, eth0, hostname, timezone, password, failure!
  

Actual Results:  reading package metadata: failure: repodata/repomd.xml from anaconda: [Errno 256] No more mirrors to try

Additional info:

sda = sata = macosx
sdb = sata = install device
sdc = usbdisk

sha1sum    media/usbdisk
FC5-test2-ppc-disc1.iso: Ok
FC5-test2-ppc-disc2.iso: Ok
FC5-test2-ppc-disc3.iso: Ok
FC5-test2-ppc-disc4.iso: Ok
FC5-test2-ppc-disc5.iso: Ok
FC5-test2-ppc-disc6.iso: Ok


tty4:
anaconda is using a deprcated SCSI ioctl, please convert it to SG_IO
Comment 1 Tobin Davis 2006-01-19 13:10:00 EST
This also happens when using text mode installation on x86 systems.  Anaconda 
fails to mount the iso images in text mode only.
Comment 2 Christian Huebner 2006-01-23 13:50:07 EST
When trying to net-install FC5 test2 it searches for repodata.xml in
Fedora/repodata and Fedora/disc1/repodata, but the repodata directory is in the
root directory of the CD. This looks like the same bug to me so I am not filing
a new one.
Comment 3 Jeremy Katz 2006-01-28 00:17:03 EST
Can you switch to tty2, grab /tmp/anaconda.log and attach it here?
Comment 4 shrek-m 2006-01-28 16:32:28 EST
Created attachment 123843 [details]
fc5t2 ppc boot.iso hdinst anaconda.log

here is the /tmp/anaconda.log
bootmedium was the fc5t2-ppc-boot.iso
Comment 5 Mike Hwang 2006-02-08 02:41:00 EST
It happened on my X86 when I use the DVD iso image for hard drive installation.
Comment 6 shrek-m 2006-04-18 15:08:15 EDT
i did not tried a hdinstall again only net-installs which were mostly ok.

closed
"mac os x"
"mac os x server"
Comment 7 Ussama Baggili 2006-06-03 01:05:45 EDT
I ran into the same issue for network install.  I tailed the access_log for my httpd and the files in RPMS 
was giving a 404.  It turns out that the directory mapping in the httpd.conf file was a little off and did 
not accommodate the RPMS and the repodata directory.

Note: I copied the directories from the FC-5-i386-DVD.iso  and -not- the CD images.  The end result, I 
think, should be the same anyway...

Here is my structure now:

--fedora5
    |
    --netowrk install
        |
        --Fedora
            |
            --base
            --RPMS
         --repodata

My repodata directory earlier was at the same level as the RPMS and base.  Anyway, after setup, there 
are a couple of tests that can be run from your favority web browser or wget

http://yourhost/yourMappingUrlForTheNetworkInstallDirectory/Fedora/RPMS/
expat-1.95.8-8.2.i386.rpm
AND
http://yourhost/yourMappingUrlForTheNetworkInstallDirectory/repodata/repomd.xml

Both should succeed.  If they don't, check your configs for the http server.  


Note You need to log in before you can comment on or make changes to this bug.