Bug 1782530 - reposync does not honor --exclude or --include from repository's configuration
Summary: reposync does not honor --exclude or --include from repository's configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf-plugins-core
Version: 8.1
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 8.0
Assignee: Marek Blaha
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-11 19:23 UTC by Brian N. Smith
Modified: 2020-06-26 15:28 UTC (History)
5 users (show)

Fixed In Version: dnf-plugins-core-4.0.12-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:49:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 4597941 None None None 2020-06-26 15:28:35 UTC
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:22 UTC

Description Brian N. Smith 2019-12-11 19:23:05 UTC
Description of problem:
reposync does not honor the exclude= in the repository configuration of the repo you are trying to sync.  (Note: previous versions in RHEL 7- behaved this way).  Similarly, the include appears to be ignored too.

Version-Release number of selected component (if applicable):
yum-utils-4.0.8-3.el8.noarch


How reproducible:
Every time.

Steps to Reproduce:
1. Create zabbix.repo file

cat <<EOF > zabbix.repo
[zabbix]
name=Zabbix 4.0
baseurl=https://repo.zabbix.com/zabbix/4.0/rhel/8/x86_64/
enabled=0
exclude=*mysql*,*japanese*
EOF

2. Run reposync command

reposync --downloadcomps \
         --config=zabbix.repo \
         --repoid=zabbix \
         --delete \
         --newest-only \
         --download-path=/patches/repository/

3. Complain that new version doesn't behave like previous version.

Actual results:
reposync downloads *mysql* & &japanese* rpms exist in downloaded repository

Expected results:
reposync should exclude any rpm containing *mysql* & &japanese*

Additional info:

Comment 1 Marek Blaha 2019-12-17 14:14:20 UTC
Thanks for reporting!
The bug is already fixed in upstream by the PR https://github.com/rpm-software-management/dnf-plugins-core/pull/368 (see related bug https://bugzilla.redhat.com/show_bug.cgi?id=1750273).

Comment 9 errata-xmlrpc 2020-04-28 16:49:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.