Bug 1782642 - dhclient failed on NIC which is not managed by NM when NetworkManager is running
Summary: dhclient failed on NIC which is not managed by NM when NetworkManager is running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-12 02:07 UTC by Fei Liu
Modified: 2020-04-28 16:54 UTC (History)
9 users (show)

Fixed In Version: NetworkManager-1.22.0-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:53:59 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:24 UTC
freedesktop.org Gitlab NetworkManager NetworkManager-ci merge_requests 517 0 None None None 2020-02-17 12:53:57 UTC

Description Fei Liu 2019-12-12 02:07:49 UTC
Description of problem:

dhclient failed on NIC when NetworkManager is running

Version-Release number of selected component (if applicable):
kernel-4.18.0-160.el8
NetworkManager :1.21.90 

How reproducible:
Always

Steps to Reproduce:
1.start system
2.Make NIC not managed by NM
3.dhclient failed on NIC

dhclient -v ens1f0
Internet Systems Consortium DHCP Client 4.3.6
Copyright 2004-2017 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/ens1f0/b8:59:9f:06:56:6c
Sending on   LPF/ens1f0/b8:59:9f:06:56:6c
Can't bind to dhcp address: Address already in use
Please make sure there is no other dhcp server
running and that there's no entry for dhcp or
bootp in /etc/inetd.conf.   Also make sure you
are not running HP JetAdmin software, which
includes a bootp server.

This version of ISC DHCP is based on the release available
on ftp.isc.org. Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report issues with this software via:
https://bugzilla.redhat.com/

exiting.

cat /etc/sysconfig/network-scripts/ifcfg-ens1f0
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=ens1f0
UUID=c056a7da-c256-4954-97d1-92128e3f1118
DEVICE=ens1f0
ONBOOT=no
NM_CONTROLLED=no

 nmcli  con
NAME         UUID                                  TYPE      DEVICE
System eno1  18edd086-7767-4622-bbb4-113a1f888f3f  ethernet  eno1

nmcli device
DEVICE  TYPE      STATE      CONNECTION  
eno1    ethernet  connected  System eno1
eno2    ethernet  unmanaged  --          
eno3    ethernet  unmanaged  --          
eno4    ethernet  unmanaged  --          
ens1f0  ethernet  unmanaged  --          
ens1f1  ethernet  unmanaged  --          
lo      loopback  unmanaged  -- 


Actual results:
dchlient failed

Expected results:
dhclient success

Additional info:

Comment 2 Thomas Haller 2019-12-12 10:17:07 UTC
only affected rhel-8.2-beta.

Comment 5 errata-xmlrpc 2020-04-28 16:53:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.