Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
When disabling IPv4 from DHCPv4 without DNS/Gateway/Route option,
nmstate will hang at NM_ACTIVE_CONNECTION_STATE_ACTIVATING or
fail with error:
NM main-loop aborted: Connection activation failed on eth2: reason=<enum NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED of type NM.ActiveConnectionStateReason>
Version-Release number of selected component (if applicable):
NetworkManager-1.22.0-0.2.el8.x86_64
nmstate-0.2.0-2.el8
How reproducible:
100%
Steps to Reproduce:
1. sudo nmstatectl set bug_eth1_dhcp4_without_other.yml
2. sudo nmstatectl set bug_eth1_disable_ip.yml
3.
Actual results:
nmstate failed.
Expected results:
No failure.
Additional info:
This is caused by on-going DHCP client. Not sure it's a NM bug or nmstate bug yet.
Created attachment 1670758[details]
verified.log
nmstate-0.2.6-4.8.el8.noarch
NetworkManager-1.22.8-4.el8.x86_64
DISTRO=RHEL-8.2.0-20200316.n.0
Linux kvm-01-guest08.lab.eng.rdu2.redhat.com 4.18.0-187.el8.x86_64 #1 SMP Sat Mar 7 03:42:33 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Verified, check the attachment "verified.log" for the details