Bug 1782701 - NM OVS: Hang at NM_ACTIVE_CONNECTION_STATE_ACTIVATING state for ovs internal port
Summary: NM OVS: Hang at NM_ACTIVE_CONNECTION_STATE_ACTIVATING state for ovs internal ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 8.2
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-12 07:32 UTC by Gris Ge
Modified: 2020-04-28 16:54 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-1.22.8-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:53:59 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
System logs with NM trace enabled (496.91 KB, text/plain)
2019-12-12 07:32 UTC, Gris Ge
no flags Details
System logs with NM trace enabled (NetworkManager-1.23.0-24609.1e9ab78bfc) (523.62 KB, text/plain)
2019-12-16 12:50 UTC, Gris Ge
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:24 UTC

Description Gris Ge 2019-12-12 07:32:40 UTC
Created attachment 1644314 [details]
System logs with NM trace enabled

Description of problem:

When activating OVS internal port, activating hang at
NM_ACTIVE_CONNECTION_STATE_ACTIVATING without further
signal callback on `state-change` of neither device or acticate connection. 

Version-Release number of selected component (if applicable):
NetworkManager-1.23.0-24592.affd60a91c.el8.x86_64 
# master of NM with fix of bug #1781165
nmstate-0.2.0-2.el8


How reproducible:
10%

Steps to Reproduce:
1. Please use the same reproduce script of bug 1781165
2.
3.

Actual results:
nmstate hang at NM_ACTIVE_CONNECTION_STATE_ACTIVATING for 30 seconds.

Expected results:

No failure.

Additional info:

Comment 1 Beniamino Galvani 2019-12-16 09:03:22 UTC
Hi Gris,

I wasn't able to understand the reason of the hang from the logs attached, and I can't reproduce the issue either.

I have prepared branch bg/rh1782701 of NM with additional debugging log messages; could you please reproduce the problem with that NM version and attach logs? Thanks!

Comment 2 Gris Ge 2019-12-16 11:28:58 UTC
(In reply to Beniamino Galvani from comment #1)
> Hi Gris,
> 
> I wasn't able to understand the reason of the hang from the logs attached,
> and I can't reproduce the issue either.

nmstate is waiting on `state-change` signal from NM.Device or NM.ActivateConnection.
But nmstate failed to get callback for 30 seconds and the activation
stuck at NM_ACTIVE_CONNECTION_STATE_ACTIVATING.

You need to try many times before hit this problem.

> 
> I have prepared branch bg/rh1782701 of NM with additional debugging log
> messages; could you please reproduce the problem with that NM version and
> attach logs? Thanks!

Will do.

Comment 3 Gris Ge 2019-12-16 12:50:27 UTC
Created attachment 1645580 [details]
System logs with NM trace enabled (NetworkManager-1.23.0-24609.1e9ab78bfc)

Comment 4 Beniamino Galvani 2020-01-17 14:52:56 UTC
Hopefully the issue is fixed by https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/402

Comment 5 Beniamino Galvani 2020-01-29 17:17:26 UTC
Hi Gris,

can you please check if the patch above fixes the problem?

Comment 7 Gris Ge 2020-02-11 06:10:50 UTC
Hi Beniamino,

With NetworkManager-1.22.7-24666.dbd7083881.el8.x86_64, I got no NM_ACTIVE_CONNECTION_STATE_ACTIVATING hang failure.

Thanks.

Comment 12 Vladimir Benes 2020-02-21 12:12:47 UTC
covered by the nmstate test executing nmstate's CI.

Comment 14 errata-xmlrpc 2020-04-28 16:53:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.