Bug 1782704 - Firefox on Wayland Addon UI Offsets make it unusable
Summary: Firefox on Wayland Addon UI Offsets make it unusable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-12 07:43 UTC by relentless.1980
Modified: 2020-02-03 01:02 UTC (History)
12 users (show)

Fixed In Version: firefox-master-3120200116134707.1 firefox-72.0.1-2.fc31 firefox-72.0.2-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-18 00:01:24 UTC
Type: Bug


Attachments (Terms of Use)
firefox-72.0.1-2.fc31 FEDORA-2020-c5f18c9518 (745.55 KB, image/png)
2020-01-17 09:01 UTC, relentless.1980
no flags Details
Firefox Nightly 74.0a1 (2020-01-16) (64-bit) (172.00 KB, image/png)
2020-01-17 09:02 UTC, relentless.1980
no flags Details


Links
System ID Priority Status Summary Last Updated
Github hackademix noscript issues 112# None None None 2019-12-12 07:43:38 UTC
Mozilla Foundation 1607404 P3 RESOLVED Firefox on Wayland: UI Offsets 2020-01-17 08:55:59 UTC

Description relentless.1980 2019-12-12 07:43:38 UTC
Description of problem:
I noticed that after the upgrade from Fedora 30 to 31 (switch to Firefox on Wayland by default) my noScript (Firefox Addon) UI was not working properly. The Bug is specific to Firefox on Wayland since one can work around the bug using Firefox on X11. I filed a bug against the addon (https://github.com/hackademix/noscript/issues/112#). 

After some discussion hackademix figured out, that this Bug is NOT ADDON SPECIFIC but FEDORA specific for addon UI elements placed to the left of the URL bar in Firefox for Wayland. It is not present on Firefox for Wayland on e.g. Ubuntu.    

Version-Release number of selected component (if applicable):
Firefox 70 and 71 tested
Fedora 31


How reproducible:
See below

Steps to Reproduce:
1. Use Firefox on Wayland under Fedora 31 and install any addon with a UI (e.g. uBlock, noScript, Tab Session Manager).
2. customize your Firefox UI to have the addon icon the left of the URL bar.
3. Try to use the addon UI (try to click on the any element of the 'drop down' UI of the addon)

Actual results:
There is an offset between the drawn UI and the action buttons. Thus the UI is not usable.

Expected results:
The UI should work as expected (action button directly below the drawn icon). 

Additional info:
Make sure to read hackademix post and have a look at the screenshots provided on Github.
https://github.com/hackademix/noscript/issues/112#issuecomment-564775368

Comment 1 Martin Stransky 2019-12-12 09:56:47 UTC
Jan, can you look at it please?
Thanks.

Comment 2 relentless.1980 2019-12-19 09:31:36 UTC
The same behaviour is also true for firefox built-in UI dropdown elements like the Downloads menu.
If you customize the UI such that the Download icon is to the left of the URL bar the little triangle (signalling that this UI dropdown menu comes out of the icon) which is usually directly under the icon as an offset.

Comment 3 relentless.1980 2020-01-07 08:06:03 UTC
I just filed a bug on Mozillas Bug Tracker: https://bugzilla.mozilla.org/show_bug.cgi?id=1607404

Comment 4 Fedora Update System 2020-01-16 09:19:24 UTC
FEDORA-2020-c5f18c9518 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c5f18c9518

Comment 5 Fedora Update System 2020-01-16 09:19:25 UTC
FEDORA-2020-4cee2fc1e7 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4cee2fc1e7

Comment 6 Fedora Update System 2020-01-16 14:53:40 UTC
FEDORA-FLATPAK-2020-9b09e97117 has been submitted as an update to Fedora 31 Flatpaks. https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2020-9b09e97117

Comment 7 Fedora Update System 2020-01-16 21:13:08 UTC
firefox-72.0.1-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4cee2fc1e7

Comment 8 Fedora Update System 2020-01-16 21:39:51 UTC
firefox-72.0.1-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c5f18c9518

Comment 9 Fedora Update System 2020-01-16 22:07:49 UTC
firefox-master-3120200116134707.1 has been pushed to the Fedora 31 Flatpaks testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2020-9b09e97117

Comment 10 relentless.1980 2020-01-17 08:56:00 UTC
I tested this by installing the update via:

$ sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-c5f18c9518

but the UI offset regression is NOT FULLY fixed for me.

The UI is usable again but the little triangle (which should be directly under the icon the dropdown menu is coming out) still has an offset.

To conclude: The functionality got fixed but there are some visual regressions left.


I also tested Firefox Nightly 74.0a1 (2020-01-16) (64-bit) directly from mozillas website: It got COMPLETLY FIXED. Is it possible to attach ScreenShots here?

Comment 11 relentless.1980 2020-01-17 09:01:18 UTC
Created attachment 1652985 [details]
firefox-72.0.1-2.fc31 FEDORA-2020-c5f18c9518

triangle not below noscript icon but on the right hand edge of the dropdown menu

Comment 12 relentless.1980 2020-01-17 09:02:15 UTC
Created attachment 1652986 [details]
Firefox Nightly 74.0a1 (2020-01-16) (64-bit)

triangle in the correct place below the noscript icon

Comment 13 Jan Horak 2020-01-17 09:55:37 UTC
The upstream version runs in xwayland, so the bug does not appear there at all. Currently the arrow issue is difficult to fix, because the GTK moves the window from negative coordinates (ie. the panel showing outside of the window to the x zero position while the Firefox has already the arrow placed). We're also unable to detect the edge of the screen because the absolute position of the window is not available under Wayland, so Firefox cannot flip the window along y axis as it does under xwayland/xorg. 

Currently Firefox is not designed that the panels are changing positions after it calculates it's dimensions. There's still a room for some improvement but we'll hardly accomplish the same behaviour we see under xwayland/xorg.

Comment 14 Fedora Update System 2020-01-18 00:01:24 UTC
firefox-master-3120200116134707.1 has been pushed to the Fedora 31 Flatpaks stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2020-01-18 20:54:22 UTC
firefox-72.0.1-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2020-01-24 19:47:36 UTC
firefox-72.0.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-8c1474367d

Comment 17 Fedora Update System 2020-02-03 01:02:32 UTC
firefox-72.0.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.