Bug 178275 - [x86_64] i386 libwmf update-gdk-pixbuf-loaders post-un failure
[x86_64] i386 libwmf update-gdk-pixbuf-loaders post-un failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libwmf (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-18 18:56 EST by Tim Mayberry
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.2.8.4-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 05:19:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Mayberry 2006-01-18 18:56:27 EST
Description of problem:

cannot remove libwmf package because of failure in %postun

Version-Release number of selected component (if applicable):

libwmf-0.2.8.4-3

How reproducible:

Steps to Reproduce:
1. Install i386 and x86_64 versions of gtk+2
2. remove gtk+2.i386 
3. remove libwmf.i386
  
Actual results:

/usr/bin/update-gdk-pixbuf-loaders: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No such file or directory
error: %postun(libwmf-0.2.8.4-3.i386) scriptlet failed, exit status 1

Expected results:

libwmf.i386 is removed.
Comment 1 Caolan McNamara 2006-01-19 05:19:57 EST
well the i386 libwmf postun would run...

> /usr/bin/update-gdk-pixbuf-loaders i386-redhat-linux-gnu

which should automatically run

> /usr/bin/gdk-pixbuf-query-loaders-32 >
/etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders

now the libwmf Requires is 

Requires(postun): %{_bindir}/update-gdk-pixbuf-loaders

Presumably the problem is that gtk2+.i386 was removed before libwmf.i386. Which
was only possible I guess because of the multilib rpm foo, where the
dependancies are not per arch rpm.

Well, we can work around this problem anyway to make it un-installable anyway.

Note You need to log in before you can comment on or make changes to this bug.