Bug 1782955 (CVE-2019-19481) - CVE-2019-19481 opensc: improper handling of buffer limits for CAC certificates
Summary: CVE-2019-19481 opensc: improper handling of buffer limits for CAC certificates
Keywords:
Status: NEW
Alias: CVE-2019-19481
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1782957 1791808 1782956 1791807
Blocks: 1782958
TreeView+ depends on / blocked
 
Reported: 2019-12-12 17:15 UTC by Guilherme de Almeida Suckevicz
Modified: 2020-01-16 14:05 UTC (History)
6 users (show)

Fixed In Version: opensc 0.20.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2019-12-12 17:15:22 UTC
An issue was discovered in OpenSC through 0.19.0 and 0.20.x through 0.20.0-rc3. libopensc/card-cac1.c mishandles buffer limits for CAC certificates.

Reference:
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=18618

Upstream commit:
https://github.com/OpenSC/OpenSC/commit/b75c002cfb1fd61cd20ec938ff4937d7b1a94278

Comment 1 Guilherme de Almeida Suckevicz 2019-12-12 17:15:43 UTC
Created opensc tracking bugs for this issue:

Affects: epel-6 [bug 1782957]
Affects: fedora-all [bug 1782956]


Note You need to log in before you can comment on or make changes to this bug.