Bug 178296 - display is too much smaller than screen
display is too much smaller than screen
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 02:52 EST by Claus Olesen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 12:58:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log (40.47 KB, text/plain)
2006-01-20 17:50 EST, Claus Olesen
no flags Details

  None (edit)
Description Claus Olesen 2006-01-19 02:52:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.3 (like Gecko)

Description of problem:
The area of the screen of my monitor used by my computer for display is   
smaller than that of the screen by 3 to 10 mm along all edges and all edges of  
the display are barrel shaped inward towards the center of the monitor. In  
other words the screen shows a display with pointy corners framed in a black  
frame.  
     
Using xvidtune I can reduce some of the error. For example, in the vertical  
direction I can reduce the error to 6mm at the center top edge and 7mm at the  
center bottom edge using "up", "down" and "taller". Further adjustment has no  
effect on the height of the display but the contents displayed starts shifting  
off the display - like panning.      
    
Monitor: Hitachi CM827 1600x1200pixels 406x305mm    
Motherboard: MSI K8MM-V    
Integrated graphics: VIA K8M800      
xorg.conf driver: via (bundled with FC5Test2)      
      
The above is after a fresh install of FC5Test2.      
     
For comparison, I then tried an add-on graphics card as replacement for the      
integrated graphics.   
      
Graphics card: Asus V9400-X/TD/64 Nvidia Geforce MX4000 64MB DDR AGP 4X/8X      
xorg.conf driver: nv (bundled with FC5Test2)      
      
With the add-on card the problem is gone. No adjustments needed whatsoever.  
And all I did is just change the driver in xorg.conf from "via" to "nv" and  
plug in the card. I did not change anything else in xorg.conf. 
 
I have 2 other computers. All 3 share the same monitor via a KVM. The other 2 
are a MSI K7N2GM-V running FC4 and an ASUS motherboard with Nvidia graphics 
running W2K - and nor do any of these 2 exhibit this problem. And I don't have 
to (and don't want to) adjust the monitor settings (using the buttons on the 
monitor) when switching computer. 
      
xorg.conf:      
     
# XFree86 4 configuration created by pyxf86config     
     
Section "ServerLayout"     
	Identifier     "Default Layout"     
	Screen      0  "Screen0" 0 0     
	InputDevice    "Mouse0" "CorePointer"     
	InputDevice    "Keyboard0" "CoreKeyboard"     
EndSection     
     
Section "Files"     
     
# Multiple FontPath entries are allowed (they are concatenated together)     
# By default, a font server independent of the X server is     
# used to render fonts.     
	FontPath     "unix/:7100"     
EndSection     
     
Section "Module"     
	Load  "dbe"     
	Load  "extmod"     
	Load  "fbdevhw"     
	Load  "glx"     
	Load  "record"     
	Load  "freetype"     
	Load  "type1"     
	Load  "dri"     
EndSection     
     
Section "InputDevice"     
     
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))     
#	Option	"Xleds"		"1 2 3"     
# To disable the XKEYBOARD extension, uncomment XkbDisable.     
#	Option	"XkbDisable"     
# To customise the XKB settings to suit your keyboard, modify the     
# lines below (which are the defaults).  For example, for a non-U.S.     
# keyboard, you will probably want to use:     
#	Option	"XkbModel"	"pc102"     
# If you have a US Microsoft Natural keyboard, you can use:     
#	Option	"XkbModel"	"microsoft"     
#     
# Then to change the language, change the Layout setting.     
# For example, a german layout can be obtained with:     
#	Option	"XkbLayout"	"de"     
# or:     
#	Option	"XkbLayout"	"de"     
#	Option	"XkbVariant"	"nodeadkeys"     
#     
# If you'd like to switch the positions of your capslock and     
# control keys, use:     
#	Option	"XkbOptions"	"ctrl:swapcaps"     
# Or if you just want both to be control, use:     
#	Option	"XkbOptions"	"ctrl:nocaps"     
#     
	Identifier  "Keyboard0"     
	Driver      "kbd"     
	Option	    "XkbModel" "pc105"     
	Option	    "XkbLayout" "us"     
EndSection     
     
Section "InputDevice"     
	Identifier  "Mouse0"     
	Driver      "mouse"     
	Option	    "Protocol" "IMPS/2"     
	Option	    "Device" "/dev/input/mice"     
	Option	    "ZAxisMapping" "4 5"     
	Option	    "Emulate3Buttons" "yes"     
EndSection     
     
Section "Monitor"     
	Identifier   "Monitor0"     
	VendorName   "Monitor Vendor"     
	ModelName    "Hitachi CM827"     
	HorizSync    31.0 - 107.0     
	VertRefresh  50.0 - 160.0     
	Option	    "dpms"     
EndSection     
     
Section "Device"     
	Identifier  "Videocard0"     
	Driver      "via"     
	VendorName  "Videocard vendor"     
	BoardName   "VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter"     
EndSection     
     
Section "Screen"     
	Identifier "Screen0"     
	Device     "Videocard0"     
	Monitor    "Monitor0"     
	DefaultDepth     24     
	SubSection "Display"     
		Viewport   0 0     
		Depth     16     
		Modes    "800x600" "640x480"     
	EndSubSection     
	SubSection "Display"     
		Viewport   0 0     
		Depth     24     
		Modes    "1600x1200" "1400x1050" "1280x960" "1280x800"     
"1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"     
	EndSubSection     
EndSection     
     
Section "DRI"     
	Group        0     
	Mode         0666     
EndSection     
     

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC5Test2 on hardware as listed in the "Description". 
2.  
3.  
    

Actual Results:  The display is too much smaller than the screen of the monitor. 

Expected Results:  The display should take up the same area as that of the screen of the monitor. 

Additional info:
Comment 1 Mike A. Harris 2006-01-20 14:43:53 EST
Do you have another monitor (any brand/size/etc.) that you could give a test
run of the onboard video on?  It'd be interesting to see if the onboard video
shows this problem for you on another monitor as well, or if it only displays
this issue on the particular display you're using.

It sounds like either some sort of driver specific timing problem, poor support
for that particular video chip in the driver, or perhaps some funky interaction
between the particular video chip and monitor combo.

Do you have an easy way to test the same video adaptor with another OS as well?
It'd be interesting to see if the problem occurs in FC4, FC3 or not too, or
even in Windows XP, or another Linux distro, etc.

Any additional information or comparisons you can provide would be helpful.

Please also attach your X server log from the problematic invocation as
a bugzilla file attachment, using the link below.

Thanks in advance.
Comment 2 Claus Olesen 2006-01-20 17:49:29 EST
For now this is what I have... 
 
I've attached a copy of the X server log - /var/log/Xorg.0.log  
  
I do have FC4. However, on FC4 I'm using the "via" driver posted by VIA  
Technologies dated 2-Dec-2005. Because FC4 does not bundle a "via" driver for  
x86_64. Still, for what it's worth, the problem is the exact same. In  
addition, no adjustment using xvidtune have any effect - the display does not  
change in any way.  
  
I just tried FC5Test2 again but after changing "via" to "vesa" in xorg.conf.  
The problem is still the exact same. xvidtune is disabled - says "video modes 
are not tunable on this chip". 
Comment 3 Claus Olesen 2006-01-20 17:50:01 EST
Created attachment 123509 [details]
X server log
Comment 4 Claus Olesen 2006-01-21 03:13:14 EST
I don't have WXP. I tried installing W2K but get a fatal error after pressing 
F6 for providing the motherboard driver CD with the SATA driver. I guess W2K 
is too old. Maybe a PATA drive would have worked but I don't have one 
available. 
 
But I did install FC5Test2 32bit. The problem is the exact same as under 
FC5Test2 64bit. 
 
Another issue. The FC5Test2 32bit installer specifies the "vesa" driver in 
xorg.conf. Here's an excerpt right after install 
 
	Driver      "vesa" 
	VendorName  "Videocard vendor" 
	BoardName   "VIA Technologies, Inc. S3 Unichrome Pro VGA Adapter" 
 
I forgot to mention that that's also the case with the FC5Test2 64bit 
installer. In both cases I changed "vesa" to "via" using an editor. 
Comment 5 Claus Olesen 2006-01-21 15:38:17 EST
I just installed SuSE10.1Beta1 64bit. Also it does not pick the "via" driver. 
Excerpt from xorg.conf  
Section "Device" 
  BoardName    "Framebuffer Graphics" 
  BusID        "PCI:1@0:0:0" 
  Driver       "fbdev" 
  Identifier   "Device[0]" 
  VendorName   "VESA" 
EndSection 
I then changed "fbdev" to "via". But in both cases the problem is still the 
exact same as under FC5Test2. (However, the graphics with "via" are much 
better than with "fbdev".) 
Comment 6 Mike A. Harris 2006-01-31 12:58:57 EST
The problem is that different video hardware all have slightly different output,
which is why displays have horizontal/vertical resizing controls, and other
controls which manipulate the final output to the screen.  In general, it is
very unlikely to have 2 separate video cards provide a signal to a display which
has 100% identical timing.  As a result, if you switch a display between
multiple computers, all using the same resolution (same video mode), the
monitor will only remember a single setting for that resolution, and you
then either need to:

1) Adjust the controls on the monitor to match the currently selected card.

or

2) Use software that is part of the OS, such as xvidtune to move/center the
   display differently.

With respect to the "barrel" like effect, the same holds true, in that
each display adaptor is different, and outputs a potentially different signal
to the display, which may be very similar to another adaptor enough that you
wont notice the difference, but alternatively which may be very different
to another adaptor in which the difference is very noticeable.  The only way
to solve that problem, is via the controls on the display, as there is no
way to work around this problem with software.  Most displays have advanced
options in their menu for slight rotation/trapezoid/barrel adjustment, etc.

The only other option that comes to mind, which is probably undesireable for
you, is to replace one of the video adaptors (or in the case of onboard video,
to add an addon board), with one with similar video output, or to buy 2
identical cards, and put one in each machine, which would increase the
likelyhood of them both having identical, or very near identical output
signals.

Setting status to "NOTABUG" - as all video hardware by nature does not
output a 100% identical signal.

Note You need to log in before you can comment on or make changes to this bug.