Bug 1782973 - kubeletconfig's description will show duplicate lines for finalizers and status
Summary: kubeletconfig's description will show duplicate lines for finalizers and status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Ryan Phillips
QA Contact: MinLi
URL:
Whiteboard:
Depends On: 1774369
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-12 17:48 UTC by Ryan Phillips
Modified: 2020-05-04 11:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1774369
Environment:
Last Closed: 2020-05-04 11:19:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1333 0 None closed [release-4.3] Bug 1782973: skip setting the kubeletconfig finalizer if it is set 2020-06-22 03:40:04 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:20:27 UTC

Comment 2 MinLi 2019-12-24 05:40:10 UTC
there are still duplicate lines for status, but no for finalizers.
version : 4.3.0-0.nightly-2019-12-23-235118

[lyman@localhost env]$ oc get kubeletconfig -o yaml 
apiVersion: v1
items:
- apiVersion: machineconfiguration.openshift.io/v1
  kind: KubeletConfig
  metadata:
    creationTimestamp: "2019-12-24T02:53:06Z"
    finalizers:
    - 99-master-f9faffee-0223-4b48-a4dc-d0bf64f37747-kubelet
    generation: 1
    name: custom-kubelet
    resourceVersion: "42189"
    selfLink: /apis/machineconfiguration.openshift.io/v1/kubeletconfigs/custom-kubelet
    uid: e25ae170-be48-45c2-b76f-6e32171020da
  spec:
    kubeletConfig:
      maxPods: 220
    machineConfigPoolSelector:
      matchLabels:
        custom-kubelet: max-pods
  status:
    conditions:
    - lastTransitionTime: "2019-12-24T02:53:06Z"
      message: Success
      status: "True"
      type: Success
    - lastTransitionTime: "2019-12-24T03:04:24Z"
      message: Success
      status: "True"
      type: Success
kind: List
metadata:
  resourceVersion: ""
  selfLink: ""

Comment 6 MinLi 2020-02-26 03:37:11 UTC
@Ryan, 
the output in comment2 include duplicate status, is it right to record timeline condition history? If it's designed as this, I think it is acceptable 
status:
    conditions:
    - lastTransitionTime: "2019-12-24T02:53:06Z"
      message: Success
      status: "True"
      type: Success
    - lastTransitionTime: "2019-12-24T03:04:24Z"
      message: Success
      status: "True"
      type: Success

Comment 9 MinLi 2020-03-09 03:51:09 UTC
reproduce on version : 4.4.0-0.nightly-2020-03-04-012453

$ oc get kubeletconfig custom-kubelet-performance  -o yaml 
apiVersion: machineconfiguration.openshift.io/v1
kind: KubeletConfig
metadata:
  creationTimestamp: "2020-03-09T03:37:44Z"
  finalizers:
  - b3208e59-b0a2-49ee-a280-84a514dd648c
  - 93d580bb-3529-4507-b9e0-7f88e090ac8a
  generation: 1
  name: custom-kubelet-performance
  resourceVersion: "41831"
  selfLink: /apis/machineconfiguration.openshift.io/v1/kubeletconfigs/custom-kubelet-performance
  uid: b071ca49-46a3-4f50-9f6c-a5e617cbfa77
spec:
  kubeletConfig: {}
  machineConfigPoolSelector:
    matchLabels:
      custom-kubelet: max-pods
status:
  conditions:
  - lastTransitionTime: "2020-03-09T03:37:45Z"
    message: Success
    status: "True"
    type: Success
  - lastTransitionTime: "2020-03-09T03:40:06Z"
    message: Success
    status: "True"
    type: Success
  - lastTransitionTime: "2020-03-09T03:46:16Z"
    message: Success
    status: "True"
    type: Success

Comment 10 Ryan Phillips 2020-03-09 13:36:43 UTC
Yes, this is correct behavior.

Comment 12 MinLi 2020-03-11 08:34:22 UTC
according to comment 10, this bug is fixed. Verified!

Comment 14 errata-xmlrpc 2020-05-04 11:19:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.