Bug 1783011 - OLM Unit Tests will not run
Summary: OLM Unit Tests will not run
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Alexander Greene
QA Contact: Bruno Andrade
URL:
Whiteboard:
Depends On: 1783014
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-12 19:42 UTC by Alexander Greene
Modified: 2020-01-23 11:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:18:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1196 0 None closed Bug 1783011: [release-4.3] Fix CI Unit tests. 2020-10-02 18:33:37 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:19:14 UTC

Description Alexander Greene 2019-12-12 19:42:00 UTC
Description of problem:
The base golang image that OLM is built from was recently updated to include the following Environment Variable: GOFLAGS="-mod=vendor".

OLM always sets "mod=venodr" in our go commands. As a result, the flag is set twice and OLM unit tests will always fail.

Version-Release number of selected component (if applicable): 4.3.0


How reproducible: Always


Steps to Reproduce:
1. Create a PR against the release-4.3

Actual results: Unit tests will not run


Expected results: Unit tests run

Comment 2 Bruno Andrade 2019-12-13 17:44:12 UTC
Created PR https://github.com/operator-framework/operator-lifecycle-manager/pull/1198 fo release-4.3 branch and ci/prow/e2e-aws-console-olm, ci/prow/e2e-aws-olm were executed successfully.

Marking as VERIFIED.

Comment 4 errata-xmlrpc 2020-01-23 11:18:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.