Bug 1783109 - Right click "Open Link in New Tab" on "Developer" from administrator console still links to administrator console
Summary: Right click "Open Link in New Tab" on "Developer" from administrator console ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-13 03:52 UTC by Junqi Zhao
Modified: 2020-07-13 17:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:12:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
perspective switcher only applicable for button (232.79 KB, image/png)
2020-05-07 08:30 UTC, Yadan Pei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5261 0 None closed Bug 1783109: Use buttons for perspective switcher dropdown items 2020-10-02 14:22:23 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:05 UTC

Description Junqi Zhao 2019-12-13 03:52:09 UTC
Description of problem:
Login administrator console and right click "Open Link in New Tab" on "Developer" from Administrator drop down list, the new tab is still for administrator console,not for Developer console

Same issue if Right click "Open Link in New Tab" on "Administrator" from Developer console

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-12-155629

How reproducible:
always

Steps to Reproduce:
1. see the description
2.
3.

Actual results:
Right click "Open Link in New Tab" on "Developer" from administrator console still links to administrator console

Expected results:
links to Developer console 

Additional info:

Comment 2 Samuel Padgett 2020-05-01 16:13:54 UTC
https://github.com/openshift/console/pull/5261 switches the item to a button, which prevents "Open Link in New Tab" from showing up in the context menu.

Comment 5 Yadan Pei 2020-05-07 08:30:42 UTC
Created attachment 1686090 [details]
perspective switcher only applicable for button

Now user can only click on the button to switch to Developer Console, no 'Open link in new tab' or 'Open in new window' context

Verified on 4.5.0-0.nightly-2020-05-06-003431

Comment 7 errata-xmlrpc 2020-07-13 17:12:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.