This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 178311 - unallowed \r escape sequence
unallowed \r escape sequence
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: diskdumputils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira Imamura
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 06:55 EST by Josep Puigdemont
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 15:07:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josep Puigdemont 2006-01-19 06:55:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
There is a message in intscripts (diskdump) that contains a non recommended escape sequence '\r':

#: /etc/rc.d/init.d/diskdump:250
msgid "Saving panic dump from swap partition:\r"

gettext tools complain that:
"internationalized messages should not contain the `\r' escape sequence"

'\r' should probably be replaced by '\n'.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Look at /etc/rc.d/init.d/diskdump line 250

Actual Results:  '\r' escape sequence found

Expected Results:  '\n' escape sequence expected

Additional info:
Comment 1 Dave Anderson 2006-01-20 09:17:27 EST

I presume that the "\r" usage was done intentionally, and that 
the subsequent $SAVECORE command output is supposed to over-write
the "Saving panic..." string: 

swapsavecore() {
        for dev in $(echo $DEVICE | tr ':' ' '); do
                $DISKDUMPFMT -c $dev 2> /dev/null
                if [ $? -eq 6 ]; then
                        echo -e $"Saving panic dump from swap partition:\r" >&2
                        $SAVECORE -D -p $dev
                        RETVAL=$?
                        echo -ne "\r" >&2
                fi
        done
}

Comment 2 Akira Imamura 2006-02-01 18:51:42 EST
As Dave said, the "\r" usage was done intentionally. It is required so as to show
a progress bar of savecore appropriately. If not "\r" but "\n" is used as
an escape sequence, then users see the following messages.

Saving panic dump from swap partition:
                                      ###############
Comment 3 Akira Imamura 2006-02-16 11:52:39 EST
Although the diskdumputils package is included in FC, diskdump facility
isn't included in FC's kernel. Consequently, if this bug is for FC, then
I won't fix anything because diskdump doesn't work with FC due to the above
reason. I don't think anyone could see the message which was written in
comment #2.

Regards,
Akira
Comment 4 Akira Imamura 2006-02-24 15:07:32 EST
I won't fix anything due to the following reasons, so I close this BZ.
- Although this does not affect to anything, many modifications will
  be required.

Note You need to log in before you can comment on or make changes to this bug.