Bug 178313 - Bad: PUP crashes upon doing an update
Bad: PUP crashes upon doing an update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-19 07:24 EST by Mark Friends
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 11:36:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Friends 2006-01-19 07:24:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:


Version-Release number of selected component (if applicable):
latest pup: 

How reproducible:
Always

Steps to Reproduce:
1. start pup in a term or command window by typing 'pup'
2.the getting update information window appears with a status bar that is increasing. 
3After that finishes you press on the apply updates button and the resolving dependecies for uptates status bar starts to increase (note I am trying to do all updates) have not tried a partial update yet.
  

Actual Results:  The update appears to start updating, but then eventually there is no change in the pup window and eventually it crashes and disapears

Expected Results:  The update process should have completed. I have never seen it complete.

Additional info:

Here is what is seen in the term window then PUP crashes whilst doing an update:


Traceback (most recent call last):
File "/usr/share/pup/pup/pup.py", line 536, in _apply
self._checkDeps()
File "/usr/share/pup/pup/pup.py", line 778, in _checkDeps
_("Unable to resolve dependencies for some "
File "/usr/share/pup/pup/pup.py", line 131, in __init__
i.set_from_stock(self._get_stock_from_type(type), 6)
AttributeError: 'NoneType' object has no attribute 'set_from_stock'

> /usr/share/pup/pup/pup.py(131)__init__()
-> i.set_from_stock(self._get_stock_from_type(type), 6)
(Pdb)

am using the latest kernel (uname -r -> 2.6.15-1.1858_FC5) on a AMD64 3000 and running FC5 in VMWare Player.
Comment 1 Jeremy Katz 2006-01-24 18:47:52 EST
Can you run rpm -V pirut?
Comment 2 Mark Friends 2006-01-26 08:25:32 EST
rpm -V pirut shows that pirut is not installed. Further when I tried to 
install it from yumex missing packages: system-config-packages is 
needed by 
package firstboot. Is pirut then needed for pup to run correctly?
Comment 3 Jeremy Katz 2006-01-26 11:36:56 EST
You're running an older version of pup (which is now a part of pirut).  This
should be good in current versions.
Comment 4 David Lawrence 2006-06-27 21:45:14 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.